xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glenn Adams (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FOP-2375) Problem while generating ps output in arabic
Date Tue, 27 May 2014 00:07:02 GMT

    [ https://issues.apache.org/jira/browse/FOP-2375?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14009159#comment-14009159
] 

Glenn Adams commented on FOP-2375:
----------------------------------

No I cannot help you, because you haven't provided adequate information to determine if there
is a problem or not. Common sense dictates that you provide an input FO file, an output PDF
file, an output PS file, your FOP config file, and any console log, both invocation command
and output. It never ceases to amaze me how people think any sense can be made of a bug report
without full data context.

Furthermore, you appear to have failed to read the documentation at [1], under "Other Limitations"
which states:

| Only the PDF output format fully supports complex scripts features at the present time.

I would suggest you use FOP to create output PDF containing Arabic, and then use an external
conversion tool to translate to PS.

[1] http://xmlgraphics.apache.org/fop/1.1/complexscripts.html

> Problem while generating ps output in arabic 
> ---------------------------------------------
>
>                 Key: FOP-2375
>                 URL: https://issues.apache.org/jira/browse/FOP-2375
>             Project: Fop
>          Issue Type: Bug
>          Components: ps
>    Affects Versions: 1.1
>         Environment: Windows 7, 2 GBram
>            Reporter: Swapnil Khante
>             Fix For: 1.1
>
>
> We are generating a ps and pdf Arabic output using Apache FOP 1.1. We are using .ttf
fonts for the same. PDF output seems to be fine but we are getting some garbage text while
generation ps output. As per Apache documentation, ps output format only supports type 1 fonts
so we have tried using .pfb fonts but problem has not resolved. When we tried generating output,
text on first page of output is fine but from page 2 onward we are getting garbage text. Observation
was that if some text is outputted on first page and again on next pages it displays fine
but when we try to output something directly on second page or on wards we are facing this
issue. Below is the entry that we are using in our .xconf file.
>     <renderer mime="application/postscript">
>       <!-- This option forces the PS renderer to rotate landscape pages -->
>       <!--auto-rotate-landscape>true</auto-rotate-landscape-->
>       
>       <!-- This option lets you specify additional options on an XML handler -->
>       <!--xml-handler namespace="http://www.w3.org/2000/svg">
>         <stroke-text>false</stroke-text>
>       </xml-handler-->
> 	  <filterList>
> 			<value>null</value>
> 		</filterList>
> 		<filterList type="image">
> 			<value>flate</value>
> 			<value>ascii-85</value>
> 		</filterList>
> 	  <fonts>&tripleFilepfb;</fonts>
> 	  <disable-srgb-colorspace>true</disable-srgb-colorspace>
>     </renderer>
> where tripleFilepfb points refers to .XML file containing .ttf fonts.
> Could you please help here? Please let me know if you need any more information.
> Thanks and regards,
> Swapnil



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message