xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Manchester (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FOP-2151) maven dependency has wrong avalon group id
Date Tue, 04 Jun 2013 03:05:20 GMT

    [ https://issues.apache.org/jira/browse/FOP-2151?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13673983#comment-13673983
] 

Daniel Manchester commented on FOP-2151:
----------------------------------------

At least with sbt (http://www.scala-sbt.org/), the build tool I'm using, it was possible to
work around this issue and still pull in FOP 1.1 as a managed dependency. More here:

http://oklampy.wordpress.com/2013/05/30/working-around-bad-dependency-declarations/
                
> maven dependency has wrong avalon group id
> ------------------------------------------
>
>                 Key: FOP-2151
>                 URL: https://issues.apache.org/jira/browse/FOP-2151
>             Project: Fop
>          Issue Type: Bug
>          Components: general
>    Affects Versions: 1.1
>         Environment: Operating System: 
> Platform: PC
>            Reporter: Lloyd
>
> The maven pom for fop 1.1 uses incorrect dependency for avalon framework. With 4.2.0
the the group id changed to avalon-framework from org.apache.avalon.framework
> workaround: update pom as follows
>  <dependency>
>   <groupId>org.apache.xmlgraphics</groupId>
>   <artifactId>fop</artifactId>
>   <version>1.1</version>
>   <exclusions>
>   	<exclusion>
>   		<artifactId>avalon-framework-api</artifactId>
>   		<groupId>org.apache.avalon.framework</groupId>
>   	</exclusion>
>   	<exclusion>
>   		<artifactId>avalon-framework-impl</artifactId>
>   		<groupId>org.apache.avalon.framework</groupId>
>   	</exclusion>
>   </exclusions>
>   </dependency>
>   <!--  these two are to correct issues in  fop dependency --> 
>   <dependency>
>    <groupId>avalon-framework</groupId>
>    <artifactId>avalon-framework-api</artifactId>
>    <version>4.2.0</version>
>   </dependency>
>   <dependency>
>    <groupId>avalon-framework</groupId>
>    <artifactId>avalon-framework-impl</artifactId>
>    <version>4.2.0</version>
>   </dependency>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message