xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From darshan pradhan <u4729...@anu.edu.au>
Subject Fwd: Re: Want to contribute
Date Fri, 27 May 2011 18:11:48 GMT
Hi All/Andreas,

The attached testcase is for the bugreport

https://issues.apache.org/bugzilla/show_bug.cgi?id=50196

As in the snapshot below/attached the test case is working at my side. 
As I have to submit my final assignment report soon for my contribution, 
I would be really glad if anyone could verify the testcase and let me 
know if I can resolve the above bug report.

If not shown please check the attachment


Thank you,
Darshan
-------- Original Message --------
Subject: 	Re: Want to contribute
Date: 	Fri, 27 May 2011 02:57:36 +1000
From: 	darshan <u4729733@anu.edu.au>
To: 	fop-dev@xmlgraphics.apache.org



Hi Andreas,

I was doing a stupid thing by putting the test file into a wrong
directory. Sorry for the unnecessary confusion. I have made the attached
testcase again for the same bug and the test is working with the svn
copy I have. Could you please check it out for me?

Thank you,
Drashan

On 25/05/11 04:08, Andreas L. Delmelle wrote:
>  On 24 May 2011, at 03:35, darshan wrote:
>
>  Hi Darshan
>
>>  <snip />
>>
>>  5. I found out the xpath values using the firefox extention XPather and then filled
in the checks accordingly.
>  OK, that works too and looks comprehensive.
>  There is an easier way, though. If you have FOP set up in an IDE (Eclipse, IntelliJ
IDEA...), then, as mentioned on the Wiki, you can just "set up a JUnit Launch configuration",
which will allow you to run the test from within your IDE. That's where those variables come
into play. If you do not set them, the entire test suite will be run. Specifying '-Dfop.layoutengine.starts-with=...'
as a VM parameter would only run those tests whose name starts with the specified string,
etc.
>
>  In that case, you have the benefit of the standard output we normally get when running
the test suite (see the output I posted earlier). If the test passes, you should also get
a clear indication that none of the checks failed and the test finished successfully.
>
>>  I have attached the .at files as well.
>>
>>  Also does follow-up attachment mean that I attached the file to the bugreport https://issues.apache.org/bugzilla/show_bug.cgi?id=50196
and close it?
>  Indeed. If we confirmed it on our end, we will then add the test to our suite, and everything
remains available in Bugzilla for future reference. If we cannot verify that it has been fixed,
we will reopen and will ask you to re-examine.
>
>  Thanks!
>
>  Regards
>
>  Andreas
>  ---




Mime
View raw message