xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jos van Roosmalen" <jos.v.roosma...@gmail.com>
Subject [FOP0.95]"Group-by" not functioning
Date Tue, 09 Dec 2008 14:34:28 GMT
Hello,

I have a problem with FOP. Consider the stripped down minimal Input XML and
XSL below.

If I run this group.xsl on input.xml using XMLSpy 2005 I get the expected
output:

<?xml version="1.0" encoding="UTF-8"?>
   Group found: group1Key
   Group found: group2Key

However if I run it using FOP 0.95 with:

fop -xml input.xml -xsl group.xsl -foout test.fo

It is complaining about the current-grouping-index():

SystemId Unknown; Line #6; Column #64; function token not found.

If I remove that current-grouping-index(), and only print Group Found:

 <xsl:for-each-group select="item" group-by="column[@index='48']">
   Group found
 </xsl:for-each-group>

I expect 2 times "Group found" but I end with an *empty* XML File:

<?xml version="1.0" encoding="UTF-8"?>

Questions:

1. Why is current-grouping-index() not working?
2. Why is even group-by not working?
3. How to get this working?

Thanks you, Jos


<?xml version="1.0" encoding="ISO-8859-1"?>
<!-- group.xsl -->
<xsl:stylesheet version="2.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" >
<xsl:template match="items">
 <xsl:for-each-group select="item" group-by="column[@index='48']">
   Group found: <xsl:value-of select="current-grouping-key()"/>
 </xsl:for-each-group>
</xsl:template>
</xsl:stylesheet>


<!-- input.xml -->
<items>
 <item><column index="48" name="mnemo">group1Key</column></item>
 <item><column index="48" name="mnemo">group1Key</column></item>
 <item><column index="48" name="mnemo">group2Key</column></item>
</items>

Mime
View raw message