xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46048] Wrong images used (how to clear image cache?)
Date Tue, 21 Oct 2008 16:36:39 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46048





--- Comment #15 from M.H. <mhilpert@gmx.de>  2008-10-21 09:36:39 PST ---
(In reply to comment #14)
> The thing is: We assume that a resource can be identified uniquely by its URI.
> After all there's the word "identifier" in "URI". If the same URI comes back,
> we assume it's the same image. The URIResolver is only used when we have to
> load the image (which is done once). The image loader framework then puts the
> loaded image (subclass of org.apache.xmlgraphics.image.loader.Image) into the
> cache under this URI, further identified by the ImageFlavor (as multiple
> representations of the same image can be stored in the image cache). So if you
> re-request the same URI again, the cache returns the image directly. No detour
> through the URIResolver.

Okay, I think I fully understood this and this is basically okay. So, the
URIResolver is no suitable way of changing these URIs, alas. So what is a
URIResolver good for, if it's just ignored in some cases (here: image cache
already has URI and doesn't call URIResolver anymore)? Even the first time my
URIResolver is called, the image cache still has the original URI instead of
the changed URI from the URIResolver. Or is this behaviour also as intended?


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message