xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46048] Wrong images used (how to clear image cache?)
Date Tue, 21 Oct 2008 10:05:36 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46048


Jeremias Maerki <jeremias@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME




--- Comment #3 from Jeremias Maerki <jeremias@apache.org>  2008-10-21 03:05:35 PST ---
Ok. What you describe is all expected and correct behaviour. Obviously, it
doesn't cover 100% of all requirements. I must say I'm not ready to believe
that it wouldn't be possible to add a unique value for the report. You managed
in the URIResolver.

One idea could be to add a set of regular expressions to match URIs that should
not be cached. We've also talked about an extension attribute on
fo:external-graphic to disable the cache for certain images. But that's all not
implemented, yet.

To put you out of you misery ;-) here's the code to clear the image cache:
fopFactory.getImageManager().getCache().clearCache();


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message