xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Hennebert" <vhenneb...@gmail.com>
Subject Re: space-start and space-end for block-areas
Date Wed, 02 Aug 2006 07:31:39 GMT
<snip/>
> > > > PS: There seems to be a problem, then, with the third paragraph
> > > > of the
> > > > attached fo file. IIUC it should be placed 1 cm right from the black
> > > > border. And if I remove the start-indent="0" attribute from the fo:block
> > > > it should be placed 2 cm right. WDYT?
> > >
> > > Yes, that's what's happening and what should be happening. I don't see
> > > the problem, sorry.
> >
> > Well, with my working copy I get the following results:
> > When start-indent is explicitly set to "0cm" for the third paragraph,
> > the text is placed 1 cm /left/ from the black border:
> > http://atvaark.dyndns.org/~vincent/ref-area_start-indent-0cm.pdf
> >
> > When start-indent is unset, the text is placed 2 cm left from the black
> > border:
> > http://atvaark.dyndns.org/~vincent/ref-area_start-indent-none.pdf
> >
> > Same result with Fop 0.92beta. My working copy is up-to-date with the
> > repository and contains no local modification. I wonder where is the
> > problem. May I ask which results do others get?
>
> Damn, I had the "break indent inheritance" switch enabled. Seems to be a
> bug then, somewhere in IndentPropertyMaker.computeConforming(). Grr.

Should I open a Bugzilla entry for that? Or submit a disabled testcase?
Or even both?

Vincent

Mime
View raw message