xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Pepping <spepp...@leverkruid.eu>
Subject Re: Error message: "Should be first"
Date Mon, 10 Jul 2006 19:17:46 GMT
On Mon, Jul 10, 2006 at 07:06:23PM +0200, Vincent Hennebert wrote:
> >One of my clients reported to me that he gets a "Should be first"
> >error
> >message on the log. This happens in (Page)BreakingAlgorithm.removeNode().
> >I get the impression that the code there is not finished rather than
> >that is a real error condition. I'll try to extend removeNode() so it
> >really removes the disabled node.
> >
> >See the attached demo file (You'll need italian hyphenation available to
> >get the error).
> >
> >I'll try to fix that tomorrow. If Luca or anyone else has any further 
> >comments
> >on that, I'd appreciate it.
> 
> I don't have any error with this file. However, I've had to change the
> font names because i_helvetica is unknown. I've tried with Helvetica and
> Helvetica + font-style="italic" (as I suppose is what the "i_" means)
> but I still don't get any error. How did you get it?
> 
> Regarding the "should be first" error, that's a part of the algorithm
> I don't completely understand, yet. That said, the removeNode method is
> called, among other places, in filterActiveNodes. This is only a guess,
> but if there is a place where the removeNode's "precondition" isn't
> respected, that might be here.

I could not reproduce the problem either. When looking at the code, it
is not clear to me why one would expect the removed node to be the
first in the list. I am surprised that this error does not occur more
often. I must be overlooking something.

Simon 

-- 
Simon Pepping
home page: http://www.leverkruid.eu

Mime
View raw message