xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39138] - block border-left/right works only if margin-left/right="0" is set
Date Wed, 29 Mar 2006 20:28:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39138>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39138


jeremias@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME




------- Additional Comments From jeremias@apache.org  2006-03-29 21:28 -------
I think the borders are only clipped in your case. In an example I've just done,
the border displayed nicely and as they should be. What's important to know is
that the border to the left and to the right is painted beyond/outside the
normal content area of the text. If you set margin-left="0mm" you trigger
certain rules that make the border appear inside the normal content area. These
rules can be found in chapter 5.3.2 in XSL 1.0.

If you want me to point out to you exactly why the border isn't shown in your
special case, please reopen the issue and attach a full FO file. Your snippet
doesn't show the reason why the border isn't painted.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Mime
View raw message