xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Geisert <christian.geis...@isu-gmbh.de>
Subject Re: Problem with building docs - which Forrest version?
Date Thu, 24 Apr 2003 16:34:01 GMT
Victor Mote schrieb:
> Christian Geisert wrote:

[ ..]

>>No big deal to fix either of these errors but I'd like first to discuss
>>which Forrest version we should use. Latest release or latest CVS?
> 
> Is this for the release? If so, I would be tempted to 1) "publish" the
> forrestbot version, then 2) just check that version out from
> icarus.apache.org/home/cvs/xml-site/targets/fop. One of the many nice things

The docs for the maintenance branch are a bit different (no Changes and
Todo pages, no Development/Alt Design) which I merged manually from HEAD
for the previous RCs. Another reason against using ths docs from
xml-site is that it would make it harder to create a distribution again
later from CVS (say build the release again in five weeks)
And I prefer changing the docs offline (forrest run) but thats just a
matter of taste..

I think I'll just temporary remove the <warning> from the <li> for RC3.

> about using forrestbot is that you let the forrest guys worry about which
> versions are stable, which skins & dtds to use, etc.

According to the webpage Forrestbot is using latest Forrest but it
doesn't seem to use the validate-sitemap target ;-)

[..]

> BTW, if you do use forrest to do a doc build, you will see some errors.
> There is an NPE when it creates compliance.html. I have narrowed it down to
> the link on the pdf icon in that document. The pdf that is generated is not
> valid, and that appears to be the cause of the problem. When I run it using
> plain old FOP (trunk, current cvs), the pdf builds fine (well, valid
> anyway), so I suspect that this is because forrestbot is using an older
> version of FOP. I expect this error to go away when they upgrade. Even
> though we get an NPE, the html file seems fine. The other errors are related
> to what looks like a font definition. I haven't tried to track it down.

The "Font specified in font.properties not found" warning only happens with
JDK1.3 under Linux and is no serious problem at all IIRC.


Christian


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-dev-unsubscribe@xml.apache.org
For additional commands, email: fop-dev-help@xml.apache.org


Mime
View raw message