serf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yosi Zion <yosi...@eldan.co.il>
Subject RE: please help - SharpSvn problem Question
Date Wed, 01 Feb 2017 06:56:06 GMT
Hi bert,
Thanks for reply

This is the "full" exception when I try to call to Merge Method
[cid:image004.png@01D27C68.7FE25CB0]

[cid:image001.png@01D27C69.05BDF0B0]


Regards,
Yosi Zion | Senior developer
Department of Information Technologies | Eldan Group


From: Bert Huijben [mailto:bert@qqmail.nl]
Sent: Tuesday, January 31, 2017 5:47 PM
To: Yosi Zion; bert@huijben.net; dev@serf.apache.org
Subject: RE: please help - SharpSvn problem Question
Importance: Low

                Hi Yosi,

I'm not sure how relevant the serf list is for this question. The users{_at_}@sharpsvn.open.collab.net<mailto:users%7b_at_%7d@sharpsvn.open.collab.net>
is probably more appropriate unless you have a more specific error message pointing towards
the 'serf' http library below Subersion.

Talking about the error message:
Can you send the complete error message instead of only the top level error? The easiest way
to obtain would be to call .ToString() on the exception instead of the .Message.

Both Subversion and .Net use nested error messages to provide more details... In this case
the message will tell you what failed on connecting to the repository: bad path, some server
error, authentication, etc. etc.

You could iterate over .InnerException on each exception, but just calling .ToString() does
all that and a bit more.


Another thing I usually try is replicating the problem with the commandline client. The Slik
Subversion client is compiled with mostly the same compiler settings and dependencies as SharpSvn,
so sometimes just using that client helps in finding a root cause.

Thanks,

                Bert

From: Yosi Zion [mailto:yosi.zi@eldan.co.il]
Sent: dinsdag 31 januari 2017 11:14
To: 'bert@huijben.net' <bert@huijben.net<mailto:bert@huijben.net>>; 'dev@serf.apache.org'
<dev@serf.apache.org<mailto:dev@serf.apache.org>>
Subject: please help - SharpSvn problem Question

Hello Bert,
How are you?

I am developing in C # with visual studio 2013,2015 and have a particular problem with SharpSvn
and I hope you can solve it for me.

Installs and downloads:
1.
I installed VisualSvnServer Version: 3.5.7 on a virtual server with the following settings:
Authentication tab - integrated windows authentication
Security tab - add permissions to my user (my user is administrator)
Certificate tab - change to my company certificate
Network tab - I use secure connection (https: //) with port 443
I add admin permission to the repository root

2. Client Side
TortoiseSVN 1.9.5, Build 27581-64 Bit
And AnkhSvn-2.6.12735

3. I downloaded the latest version of SharpSvn (SSvn-1.9005.3934.158-x64)

Problem Description:
When I'm trying to merge through the UI TortoiseSVN everything works fine and it perform the
merge and the commit to the repository/
When I try to do this through C# code with SharpSvn I get a message "Unable to connect to
a repository at URL 'https://MyServer.co.il/svn/noam2/Yosi/NorthwindTrunk2/Trunk'"
After call client.Merge(qa_work_copy, mergeFrom, revisionsRange, mergeArgs);
I think I tried everything:
I tried without Authentication of user and password
I tried Authentication of user and password via client.Authentication.ForceCredentials
I signed up for all the events of Authentication and some even not fired,
For example:
SharpSvn.Security.SvnSslServerTrustEventArgs
Authentication_SslClientCertificatePasswordHandlers

I even set the DefaultCredentials via System.Net.NetworkCredential(user, password) without
any success

Incidentally, I am successful to perform the Update action using an SharpSvn

I enclose you snippets of code I wrote to those who succeeded and those that failed
I do not know what to do about it and the more I will be happy if you can help me solve this
problem.

Some Screenshots:

[cid:image006.png@01D27C68.7FE25CB0]

[cid:image007.png@01D27C68.7FE25CB0]


[cid:image008.png@01D27C68.7FE25CB0]

Regards,
Yosi Zion | Senior developer
Department of Information Technologies | Eldan Group


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message