ripple-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Horn, Julian C" <julian.c.h...@intel.com>
Subject RE: What version of node.js does Ripple require?
Date Tue, 21 Apr 2015 13:22:46 GMT
I submitted a pull request to update jsdom and bower.
I have observed that the older bowser doesn't successfully add jasmine
to the thirdparty folder.  Newer versions work on windows, linux and mac.

I think node version 0.11.x is a reasonable lower bound for the supported node version.
I'm using node version 0.12.0 myself.

BTW, it is not sufficient to avoid using the caret notation for semver in package.json.
Other components pulled in by jslint and uglify-js themselves use the caret notation.
If you rip out jake, jshint, csslint and uglify-js and try to run the first line
in configure with an npm version that doesn’t understand carets it will fail.
> npm install -g jake jshint csslint uglify-js

    Julian

-----Original Message-----
From: Tim Barham [mailto:Tim.Barham@microsoft.com] 
Sent: Tuesday, April 21, 2015 1:51 AM
To: dev@ripple.incubator.apache.org
Subject: RE: What version of node.js does Ripple require?

Yeah, I verified all the tests pass with the changes Julian proposes, so I agree we should
go ahead with that. Of course I have an ulterior motive - some changes I'm currently working
on (dev only) require at least Node 0.11.12, so I'd like to update our Node requirement :).

> > Also, Ripple's package.json contains version references using the 
> > caret notation.
>
> I am a proponent of just freezing all the versions, to fix this, and 
> to keep things consistent. ?

If we move to a newer version of node and npm, is there a reason to avoid the caret notation?
That means we should only get backwardly compatible versions (yeah, I know, I'm sure not everyone
is rigorous about sticking to that), and we gain the advantage of potentially getting bug
fixes.

Tim

-----Original Message-----
From: Brent Lintner [mailto:brent.lintner@gmail.com]
Sent: Tuesday, April 21, 2015 6:11 AM
To: dev@ripple.incubator.apache.org
Subject: Re: What version of node.js does Ripple require?

Ah! Thanks a bunch Julian!! I had noticed this with future versions but didn't have a chance
to look in depth. :-(

>> Is there any reason I shouldn't upstream this change?

IMO, if things are all good and `jake test` runs smoothly, then, please do!
:-D

>> Also, Ripple's package.json contains version references using the 
>> caret
notation.

I am a proponent of just freezing all the versions, to fix this, and to keep things consistent.
?

>> What version of node and npm does Ripple require nowadays.

Ideally, the latest, as it used to be assumed (since having such out of date deps being left
:-S).

On Mon, 20 Apr 2015 at 13:26 Horn, Julian C <julian.c.horn@intel.com> wrote:

> What version of node and npm does Ripple require nowadays?
> The README just says node and npm are required, but it doesn't say 
> anything about versions.
>
> There are some known compatibility issues between modules used by 
> Ripple and newer versions of node.
> Specifically, jsdom is pegged to version 0.6.x (0.6.5) in the 
> package.json and this doesn't work with node 0.11.x.
> You get this error when you run "jake test":
>
> RangeError: The normalization form should be one of NFC, NFD, NFKC, NFKD.
>
> See https://github.com/tmpvar/jsdom/issues/769 for more details.
>
> Also, Ripple's package.json contains version references using the 
> caret notation.
> This means older versions of npm don't work.
> If you install the pre-built installer for node 0.10.5, you get npm 
> version 1.2.18 and it doesn't do carets.
> This means the configure script will fail unless you explicitly update 
> your npm version.
>
> I got node versions 0.11.15 and 0.12.0 to work, after I upgraded the 
> jsdom version from 0.6.x to 3.0.1 in the package.json.
> Is there any reason I shouldn't upstream this change?
>
>
>
>
>
>
>
Mime
View raw message