portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Iwan Flameling <iwanov...@gmail.com>
Subject Re: Building custom portal project does't use mirror settings
Date Thu, 27 Dec 2012 15:38:55 GMT
Dear devs,

Sorry for bothering. I had to put my mirror settings in the portal's 
jetspeed-mvn-settings.xml. The portal now builds succesful. Thanks.


Kind regards,
Iwan.

On 12/21/2012 05:18 PM, Iwan Flameling wrote:
> Beste Ate en andere devs,
>
> I have to use a mirror for maven central and want to setup a custom 
> portal using the Buildguide 
> (http://portals.apache.org/jetspeed-2/buildguide/jetspeed-archetype.html). 
> When running "mvn jetspeed:mvn -Dtarget=all" I encounter the following:
>
> /[INFO] Building myportal portal
> [INFO]    task-segment: [clean, install]
> [INFO] 
> ------------------------------------------------------------------------
> Downloading: 
> http://repo1.maven.org/maven2/org/apache/portals/jetspeed-2/jetspee
> d-unpack-maven-plugin/2.2.2/jetspeed-unpack-maven-plugin-2.2.2.pom
> /
>
> I don't have an ability to connect to the internet. I can only use our 
> internal repository that proxies maven central. It looks like the 
> build of the portal ignores my mirror settings.
> I'm using the jetspeed 2.2.2 archetype and maven 2.2.1 with the 
> following settings.xml:
>
> /<settings xmlns="http://maven.apache.org/POM/4.0.0">
>
> <localRepository>c:/Users/<user>/.m2/repository/</localRepository>
> /
>
> / <mirrors>
> <mirror>
> <id>artifactory.default</id>
> <url>http://qar4034/artifactory/libs-release</url>
> <mirrorOf>*</mirrorOf>
> </mirror>
> </mirrors>
>
> <pluginGroups>
> <pluginGroup>org.apache.portals.jetspeed-2</pluginGroup>
> </pluginGroups>
>
> </settings>
> /
>
> I encountered a similair problem with jetspeed 2.1.3, where I needed 
> to bugfix maven ant tasks 
> (http://jira.codehaus.org/browse/MANTTASKS-157?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel).
> In this case I was unable to clarify where it goed wrong.
>
> Could you please help me out or give any feedback on what I might be 
> doing wrong?
>
>
> Vriendelijke groet,
> Iwan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message