portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lance Zhang <lzhan...@yahoo.com>
Subject Re: Jetspeed Questions regarding WebSphere
Date Wed, 29 Jul 2009 01:35:54 GMT
thank you David for the answers,

I found out that the VersionedPortletApplicationManager is only available in 2.2 not in the
2.1.3. Then i have tried the 2.2 on WebSphere I followed the "EAR deployment" section
and still got the class incompatible error. The problem is the class in the WebSphere container
are loaded as the EXT class loader, which is at the top. All the classes we put in the EAR,
including the portlet api are lower in the hierarchy. In order to load the EAR class first,
 i will then have to reverse the order of the class loader. That could be undesired. Maybe
you can help to point me out if i did wrong. And will the VersionedPortletApplicationManager
work in the 2.1.3?

Another question is that we have the requirements for the user to customerize the layout their
desktop using drag and drop, i am trying to see if the web 2.0 based desktop customizer can
fit, is there any document on this topic? And i assume that once the user changes his layout,
it will be a new psml for him, am i correct?


----- Original Message ----
From: David Sean Taylor <d.taylor@onehippo.com>
To: Jetspeed Developers List <jetspeed-dev@portals.apache.org>
Sent: Tuesday, July 28, 2009 2:16:39 PM
Subject: Re: Jetspeed Questions regarding WebSphere

On Jul 27, 2009, at 2:24 PM, Lance Zhang wrote:

> HI,
> I am trying to get Jetspeed to run on the WebSphere 6.1.
> I have the following questions:
> 1.    I want to know if there is any packaged DLL existing to create schema and pre populate
the DB for Oracle.

I am sorry, we don't provide DDL and SQL scripts per database. We prefer to generate the DDL
from a DB-neutral DDL XML format, and then populate the database from also DB-neutral domain-specific
XML language. With experience we have discovered this process works great once you get past
the high learning curve of a Maven-2 build. The problem is that people are often so discouraged
by the build that they simply give up. We have also discovered that at big companies, the
database teams really prefer to have SQL seed scripts over Java-utilities that populate the
database over JDBC. Anyway, this is the status of things now, so we have to work with it.
I could send you the DDL, but then we would still have to somehow get you the SQL scripts
to populate the basic seed data, which is currently not available.

Just to get started with building, take a look at the build guide can be found here:


> 2.jetspeed-2.2.0.jar was not found.was thrown when i use the jetspeed-db:ddl plugin.

As for why you are receiving the error, Im not sure. That file does not exist there. I am
not sure why that is happening, as we should be checking against Maven remote repositories
such as Apache and Bluesunrise first.  I recommend another approach: try to build a custom
build of Jetspeed as described here:


> 3, i installed the 2.2 using the jar installer, and using the ant task migrated to Oracle,
then connect using WebSphere. While i started the websphere, there is an error, PortletContext.getContainerRuntimeOptions()
Class Element not found exception. After some research, the WAS 6.1 has its own portlet container,
and its class were loaded at the root of the class loader hierarchy. This method is new to
the Portlet 2.0 spec and therefore, it doesn't work.

Have you read through the documentation on deploying to Websphere here?:


> 4. I tried the above method using 2.1.3, and i am able to run the Jetspeed. However,
i found there is a new issue, i am trying to connect the tomcat version and WebSphere version
to the same Oracle DB. and i found i can only start one of them, not both. the reported error
relates to the checksum of the j2-admin and then all the portlets has to be de-registered.
My questions is will the jetspeed run in clustered environment? If i have 2 WebSphere nodes
connecting to one Oracle DB, will that work?

The default deployment component will have difficulties in a cluster. Recommend using an alternate
Spring configuration with the VersionedPortletApplicationManager:


> 5. While i am running Jetspeed in WebSphere, i enabled j2EE security on WebSphere. Then
i found out the admin and the devmgr user ids are no longer working. I have add those 2 ids
in LDAP with correct password, is there anything else i need to do to enable these?

I've always disabled J2EE security on the Jetspeed webapp and used Jetspeed's internal security
directly. Jetspeed does by default use a J2EE Login Module (I disable it on Websphere), however
I never succeeded in getting it to work with Websphere. Im sure if you dig around a bit more
you can figure it out


To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org

View raw message