portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ate Douma (JIRA)" <jetspeed-...@portals.apache.org>
Subject [jira] Commented: (JS2-973) Running Jetspeed 2.2 on Websphere 6.1 / Oracle10
Date Mon, 11 May 2009 14:49:45 GMT

    [ https://issues.apache.org/jira/browse/JS2-973?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12708063#action_12708063

Ate Douma commented on JS2-973:

I've pinned down and solved one of the three session related JSR-286 TCK test failures.

First of all, when running on Websphere, the custom PortalRequestFactoryImpl as defined in
WEB-INF/assembly/wps.xml needs to be enabled.
This factory wraps the real Websphere request to keep its own reference of the portal contextPath,
servletPath and session.
This is needed as this request scoped "data" is maintained dynamically by Websphere and thus
can change depending on the webapp context you're currently in.
As the portal request data needs to be accessible (within Jetspeed Portal that is), even across
multiple web applications, this wrapper is required.

The bug I just found is that the wrapped request (PortalRequest) also implements the ContainerRequiredRequestResponseWrapper
(which I did myself).
This marker interface is intended to be used to prevent unwrapping before a cross context
portlet dispatch is invoked. 
In this case however, this unwrapping actually *is* required as without that, the dispatched
portlet webapp will incorrectly be viewing the (cached) portal request session etc. data.

Removing the ContainerRequiredRequestResponseWrapper interface solved one of the three session
related TCK test failures. I'll commit this change shortly.

> Running Jetspeed 2.2 on Websphere 6.1 / Oracle10
> ------------------------------------------------
>                 Key: JS2-973
>                 URL: https://issues.apache.org/jira/browse/JS2-973
>             Project: Jetspeed 2
>          Issue Type: Task
>    Affects Versions: 2.2.0
>            Reporter: Ate Douma
>            Assignee: Ate Douma
>             Fix For: 2.2.0
> Testing current Jetspeed 2.2-SNAPSHOT on Websphere 6.1 I;'ve encountered some issues
which I'm recording here for the record and/or as outstanding TODO tasks.
> - xml-apis jar: all the JAXP apis are now part of Java5+ and having this jar in WEB-INF/lib
causes problems on Websphere
>   TODO: remove/exclude this dependency in maven poms
> - stax-api-1.0.1.jar: this artifact (incorrectly) contains javax.xml.namespace.* classes
(QName specifically) which breaks JAXB on Websphere
>   TODO: upgrade to stax-api-1.0.2.jar which no longer contains the javax.xml.namespace
for SECURITY_DOMAIN.UIX_DOMAIN_NAME for an Oracle database
>   During creation of the schema in the database the trigger code fails to be created.
However, both the sequence and the trigger are not needed anyway.
>   TODO: figure out how to disable the sequence and trigger generation from DDLUtils

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org

View raw message