portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sean Taylor <da...@bluesunrise.com>
Subject Re: Fwd:
Date Mon, 24 Sep 2007 23:47:37 GMT
On Sep 14, 2007, at 5:28 AM, Lucio Savino wrote:

> Hi all,
> I tried to add jetspeed schema to the Apache DS server following  
> this guide:
> http://portals.apache.org/jetspeed-2/multiproject/jetspeed-security/ 
> ldap.html
> I modified the server.xml file as described in the guide and then I  
> added the jar file, downloaded from http://people.apache.org/ 
> ~taylor/LDAP/jetspeed-security-schema-2.1.3-dev.jar, in the Apache  
> DS lib directory.
> I use Apache DS 1.0.2.
> At the start up of Apache DS, the class that I specified in  
> server.xml for the jetspeed bean  
> (org.apache.jetspeed.security.ldap.JetspeedSchema) searches the  
> AbstractBootstrapSchema class in org/apache/ldap/server/schema/ 
> bootstrap/. This class was in this position in the previous version  
> of Apache DS (I think 0.93), but in the 1.0.2 version it is in org/ 
> apache/directory/server/core/schema/bootstrap, and so I have a  
> ClassNotFoundException.
>
> Can Anybody help my?
>
We are compiling against the 0.9.3 version of Apache DS
I looked into building against 1.0.2, problem is I can't find a maven- 
directory-plugin for version 1.0.2
Out on ibiblio they only seem to go up to 0.9...
So we are stuck on 0.9 until we can get a plugin to correctly  
generate our schema classes for 1.0.2
I suppose it may be interesting to just skip over to 1.5 which  
doesn't seem to need this compilation phase, but I haven't tried it
For the next release Im going to leave things at 0.9.3


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message