portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Evans" <aaronmev...@gmail.com>
Subject Re: broken build!?!
Date Mon, 14 Aug 2006 13:16:11 GMT
I've never seen the wiki one before, just this getting started doc.
In general, I don't really trust wikis.  People tend to post great
initial documentation but never get around to updating it...

On 8/11/06, John Langley <langleyj@telcordia.com> wrote:
> So... by following a different set of docs, the ones found here:
> http://portals.apache.org/jetspeed-2/getting-started-source.html
>
> I got things to work.
>
> Thanks anyway to anyone who might have read my email and looked at ways
> to help.
>
> One of the questions I have though is why are there differences between
> the wiki instructions and the instructions above... and should the wiki
> site ones be changed? (Perhaps they're old 'targets').
>
> Langley
>
>
>
> On Fri, 2006-08-11 at 15:16 -0400, Langley, John wrote:
> > Folks, I'm new to jetspeed2 and although the functionality looks great
> > (excellent job!) the current build seems to be broken.
> >
> >
> >
> > I've tried doggedly to get both trunk and   JETSPEED-RELEASE-2.0 (as
> > checked out of svn) to build, by the directions listed here:
> > http://wiki.apache.org/portals/Jetspeed2/QuickstartForTheImpatient/Build
> > UsingMaven
> >
> >
> >
> > With the following versions:
> >
> > OS: linux fedora core 5 (2.6.16-1.22122_FC5)
> >
> > Jdk: 1.5.0_7-b03
> >
> > Tomcat: 5.5.17
> >
> > Maven: 1.0.2
> >
> >
> >
> > My build properties file is:
> >
> > ant.home = /usr/local/ant
> >
> > org.apache.jetspeed.server.home = /usr/local/tomcat
> >
> > org.apache.jetspeed.server.shared=/usr/local/tomcat/shared/lib
> >
> > org.apache.jetspeed.deploy.war.dir=/usr/local/tomcat/webapps
> >
> > org.apache.jetspeed.services.autodeployment.user=j2deployer
> >
> > org.apache.jetspeed.services.autodeployment.password=j2deployer
> >
> > org.apache.jetspeed.catalina.version.major=5.5
> >
> > org.apache.jetspeed.project.home=/opt/home/jlangley/lab/jetspeed/jetspee
> > d2-release2.0
> >
> > org.apache.jetspeed.portal.home=/opt/home/jlangley/lab/jetspeed/jetspeed
> > 2-release2.0
> >
> >
> >
> > You'll note the directory is a copy of JETSPEED-RELEASE-2.0 that I
> > checked out of svn
> >
> >
> >
> > The following steps work fine:
> >
> > % maven initMavenPlugin
> >
> > % maven allClean allBuild
> >
> >
> >
> > But
> >
> > % maven allSite
> >
> > Fails after running for some time with the following error
> >
> >
> >
> >     [exec]  __  __
> >
> >     [exec] |  \/  |__ _Apache__ ___
> >
> >     [exec] | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> >
> >     [exec] |_|  |_\__,_|\_/\___|_||_|  v. 1.0.2
> >
> >     [exec]
> >
> >     [exec] Attempting to download standalone-compiler-3.6.1.jar.
> >
> >     [exec] The build cannot continue because of the following
> > unsatisfied dependency:
> >
> >     [exec]
> >
> >     [exec] standalone-compiler-3.6.1.jar
> >
> >     [exec]
> >
> >     [exec] Error retrieving artifact from [
> > http://cvs.apache.org/repository/izpack/jars/standalone-compiler-3.6.1.j
> > ar]: java.io.IOException: Unknown error downloading; status code was:
> > 302
> >
> >     [exec] WARNING: Failed to download standalone-compiler-3.6.1.jar.
> >
> >     [exec] Total time: 8 seconds
> >
> >     [exec] Finished at: Fri Aug 11 14:52:22 EDT 2006
> >
> >     [exec]
> >
> >
> >
> > BUILD FAILED
> >
> > File......
> > /opt/home/jlangley/lab/jetspeed/jetspeed2-release2.0/maven.xml
> >
> > Element... exec
> >
> > Line...... 129
> >
> > Column.... 127
> >
> > null returned: 100
> >
> > Total time: 10 minutes 59 seconds
> >
> > Finished at: Fri Aug 11 14:52:22 EDT 2006
> >
> >
> >
> > [jlangley@prospero jetspeed2-release2.0]$
> >
> >
> >
> > Note: the trunk checkout build breaks in exactly the same way. I tried
> > nuking the maven cache (~/.maven/cache) but that didn't help. And sure
> > enough
> > http://cvs.apache.org/repository/izpack/jars/standalone-compiler-3.6.1.j
> > ar doesn't exist.
> >
> >
> >
> > Thanks in advance for helping me get jetspeed2 to build!
> >
> >
> >
> > Langley
> >
> >
> >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message