portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sean Taylor <da...@bluesunrise.com>
Subject Re: Jetspeed-2 Build Problems - Workaround
Date Mon, 17 Nov 2003 23:12:57 GMT

On Monday, November 17, 2003, at 08:53  PM, David Le Strat wrote:

> All,
>
> There seem to be a problem with Jetspeed 2 build. When
> HW_App gets deployed it uses the
> PortletApplicationManager in order to persist the
> portlet configuration to the database.  However, given
> that you have a build.properties under ${user.home}
> (in Windows, it typically is C:\Documents and
> Settings\Your Name), it will look for a alternate
> dbAlias. If the db alias is not available, which most
> likely will not, the portlets information will get
> persisted to the default location,
> ${jetspeed.home}/portal/src/webapp/WEB-INF/db/hsql
>
Look at the GETTING-STARTED.doc, step 2, "build.properties settings"
See the documentation for setting the 3rd property: deployment.db.alias

I agree that this solution is not optimal and leads to installation 
failures.
The whole point of putting the database into the web application was to 
make Jetspeed easier to use out of the box.
Since this is obviously not happening, perhaps we should drop a 
preconfigured Hypersonic database in the webapp, and require special 
installation steps to formally install and configure the database.





---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message