portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roger Ruttimann" <roger.ruttim...@earthlink.net>
Subject Re: Jetspeed 2 - deploy demo app problem
Date Wed, 15 Oct 2003 05:38:17 GMT
I'm not sure where to find the maven-0.9-and -up.xml.
Most people use maven 1.0-beta-10.

Maybe your database is not correct. Before you deploy the demo call
maven db.recreate

Hope it helps
Roger

----- Original Message ----- 
From: "WangXuSheng (王绪胜)" <wxs@founder.com>
To: "Jetspeed Developers List" <jetspeed-dev@jakarta.apache.org>; "Roger
Ruttimann" <roger.ruttimann@earthlink.net>
Sent: Tuesday, October 14, 2003 3:15 AM
Subject: 答复: Jetspeed 2 - deploy demo app problem


I've follow the setup steps except for renaming maven-0.9-and-up.xml to
maven.xml  because I did not find the file  maven-0.9-and-up.xml in CVS.
But I get the file from mail-archive, the error still exists.
I don't know whether I get the correct version for  maven-0.9-and-up.xml or
not ,can anyone give me that file?
My  ${USER_HOME}/build.properties file reads following:

CATALINA_HOME = d:/jakarta/tomcat4.1
catalina.home=${CATALINA_HOME}
catalina.shared.lib = ${CATALINA_HOME}/shared/lib/
deploy.war.dir = ${CATALINA_HOME}/webapps/
deployment.db.alias =
${CATALINA_HOME}/webapps/jetspeed/WEB-INF/db/hsql/Registry
locale.default=en
maven.ant.generatebuild.file=generated_mavnen_build.xml

Is that right ? any help is appciated.

I use tomcat  4.1.18 + JDK1.4.1, Windows 2000 Server, Maven 1.0 beta
I've tried tomcat 4.1.27,  the error still exists.


-----原始邮件-----
发件人: Roger Ruttimann [mailto:roger.ruttimann@earthlink.net]
发送时间: 2003 10 13 23:40
收件人: Jetspeed Developers List
主题: Re: Jetspeed 2 - deploy demo app problem



Did you follow all the setup steps in getting-started document (./docs)?
It's important that your build.properties is correct.

Roger

-----Original Message-----
From: Wang Xusheng <wxs_pku@hotmail.com>
Sent: Oct 13, 2003 2:42 AM
To: jetspeed-dev@jakarta.apache.org
Subject: Re: Jetspeed 2 - deploy demo app problem

I've get  the latest CVS ( Oct 13 2003) for the demo app,but the error
still exists.
I havn't  HW_APP folder in my tomcat/webapps
It seems that portlet deployment error.
Did I miss anything?  Any help is appreciated.



>-----????-----
>???: Roger Ruttimann [mailto:roger.ruttimann@earthlink.net]
>????: 2003 10 11 0:31
>???: Jetspeed Developers List
>??: Re: Jetspeed 2 - deploy demo app problem
>
>
>Make sure that you get the latest CVS for the demo app.
>Make sure that you don't have already HW_APP folder (read only?) in your
tomcat/webapps directory
>
>Roger
>
>-----Original Message-----
>From: Wang Xusheng <wxs_pku@hotmail.com>
>Sent: Oct 9, 2003 6:01 PM
>To: jetspeed-dev@jakarta.apache.org
>Subject: Jetspeed 2 - deploy demo app problem
>
>I encountered problems while deploying demo app.It  reports following:
>
>pam.deploy:
>     [java] 0 [main] INFO jetspeed.Jetspeed  - Jetspeed environment
>attempting to
>  initialize portal Engine...
>     [java]
>file:/D:/Jakarta/Tomcat4.1/webapps/jetspeed/WEB-INF/conf/ojb/OJB.properties

>     [java]
>file:/D:/Jakarta/Tomcat4.1/webapps/jetspeed/WEB-INF/conf/ojb/OJB.properties

>     [java]
>file:/D:/Jakarta/Tomcat4.1/webapps/jetspeed/WEB-INF/conf/ojb/OJB.properties

>     [java] 09 ?? 2003 16:27:25  INFO [main]
>(org.apache.jetspeed.engine.JetspeedEngine.init:152) - Creating portlet
>container...
>     [java] JMX locked by operation init
>     [java] JMX released by operation init
>     [java] Calling FileSystemPAM...
>     [java] deploying WAR file'demo.war' to WEB-INF/...
>     [java] Libraries and classes deployment finished!
>     [java] prepare web archive
>'D:/Jakarta/Tomcat4.1/webapps/HW_App/WEB-INF/web.xml' ...
>     [java] Exception in deploy. Rollback of application deployment...
>     [java] Rollback: Remove D:/Jakarta/Tomcat4.1/webapps/HW_App and all
>sub-directories.
>     [java] Unhandled exception while ading elements to the web.xml file.
>     [java] Connection refused: connect
>     [java] JMX locked by operation shutdown
>     [java] stopping RMI registry
>     [java] JMX released by operation shutdown
>     [java] Done
>
>How to solve the prolem ?  Any help is appreciated!
>
>_________________________________________________________________
>??????????????? MSN Hotmail?  http://www.hotmail.com
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org
>

_________________________________________________________________
??????????????? MSN Hotmail?  http://www.hotmail.com


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message