portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 21232] New: - JSP Portlet not working in 1.4-b4 w/Tomcat 5
Date Tue, 01 Jul 2003 15:13:41 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21232>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21232

JSP Portlet not working in 1.4-b4 w/Tomcat 5

           Summary: JSP Portlet not working in 1.4-b4 w/Tomcat 5
           Product: Jetspeed
           Version: 1.4b5-dev / CVS
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: JSP
        AssignedTo: jetspeed-dev@jakarta.apache.org
        ReportedBy: grenoml@yahoo.com


Ref: Tomcat Bugzilla Bug 21206

  Using Tomcat 5.0.3, Jetspeed will not display the contents of any of the JSP
Portlets just their title bars.  And the only way that I have found to get these
JSP Portlets to display is to select 'Edit account' at the top of the Jetspeed
page and then just cancel on the next page.  Jetspeed JSP Portlets just do not
work right with Tomcat 5.0.3.  

  Let me clarify this a little more.  Once you have installed the jetspeed.war
file go to the jetspeed home page http://localhost:8080/jetspeed .  Login as
user 'turbine', password 'turbine'.  Now, all the default portlets you see on
the page are Velocity Portlets.  You have to actually add JSP Portlets to the
pages before you can even begin to see the problem.   Click on the 'Edit HTML'
link and select Home then select 'Add Portlet' and from the list of portlets
select some of the JSP types such as JSP HelloWorld or JSP Stock Portfolio (on
the next page), save and apply your way out and then you should be able to see
the problem.

  I not inclined one way or the other to say whose issue this is.  It could be
either a Tomcat or a Jetspeed issue at this point. The behavior doesn't occur in
4.1.24 or Resin. 

thx,
Gerry Reno

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message