portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 20422] New: - WAP support
Date Mon, 02 Jun 2003 16:15:04 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20422>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20422

WAP support

           Summary: WAP support
           Product: Jetspeed
           Version: 1.4b4
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: WML
        AssignedTo: jetspeed-dev@jakarta.apache.org
        ReportedBy: helder@dsi.uminho.pt


I describe several problems with the WAP support:

1. When accessing the WAP portal (JSP version), I'm directly sent to the 
anonymous profile, instead of being presented with a login form, as it happens 
with the Velocity version. I've developped a new default layout template for 
WML in JSP:

<?xml version="1.0"?><!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 
1.1//EN" "http://www.wapforum.org/DTD/wml_1.1.xml">
<%@ taglib uri='/WEB-INF/templates/jsp/tld/template.tld' prefix='jetspeed' %>

<wml>
  <jetspeed:navigation  defaultTemplate="wml/top.jsp" />
  <jetspeed:navigation  defaultTemplate="wml/login.jsp" />
  <jetspeed:navigation  defaultTemplate="wml/bottom.jsp" />
</wml>

and also a login navigation template (login.jsp) that presents either the user 
profile either the login form (in the case the user is not logged in):

<%@ taglib uri='/WEB-INF/templates/jsp/tld/template.tld' prefix='jetspeed' %>
<%@ page import = "org.apache.jetspeed.services.resources.JetspeedResources" %>
<%@ page import = "org.apache.turbine.util.RunData" %>
<%
   RunData data = (RunData) request.getAttribute("rundata");                 
   String screenJsp = (String)request.getAttribute("screenJsp");

   if (data.getUser().hasLoggedIn())
   { %>
     <jsp:include page="<%= screenJsp %>" flush="true" />
<% }
   else
   { %>
     <card id="Login">
       <p align="center">
       <b><jetspeed:l10n key="TOP_TITLE"/></b><br/>
       </p>
       <do type="accept" label="login">
         <go href="<jetspeed:dynamicUri/>" method="post">
           <postfield name="password" value="$(password)" /> 
           <postfield name="username" value="$(username)" />
           <postfield name="action" value="<%=JetspeedResources.getString
("action.login")%>" />
           <setvar name="action" value="" />
           <setvar name="username" value="" />
           <setvar name="password" value="" />
         </go>
       </do>
       <p><jetspeed:l10n key="USERFORM_USERNAMEMSG"/><input name="username"

type="text" size="5" value="" emptyok="false" maxlength="25"/></p>
       <p><jetspeed:l10n key="USERFORM_PASSWORDMSG"/><input name="password"

type="password" size="5" value="" emptyok="true" maxlength="25"/></p>
     </card>
<% } %>

2. The WML customizer does not allow to select other controllers than "Single 
Row". I think it should. However, the controller that is associated to WML 
profiles is always FlowPortletController, which does not make sense.

2. The FlowPortletController controller template does not have a correct action 
defined for logout. It should be "JLogoutUser". Besides that, it is 
unnecessarily complex. Here goes my version of the template:

##modified: Andreas Kempf, 12/10/01
## added support for LinkPortlet
##---------------------------------
<card title="User Home">
  #parse("welcome.vm")
  <p><br/>

#foreach ( $portlet in $portlets )
  <a href="#_$!portlet.Name">$!portlet.Title</a><br/>
#end

## add Logout link
  <br/>
  <img src="$clink.getExternal()images/wml/exit.wbmp" alt=""/>
  <b><a href="$link.setAction("JLogoutUser")">Logout</a></b><br/>
  </p>
</card>
#foreach ( $portlet in $portlets )
  $!portlet.getContent($data)
#end

3. After adding a new portlet in the WML customizer, switching to a WAP 
browser, and trying to see the modifications in the profile, it yields an error 
inside the WML code (in the place of the added portlet):

org.apache.turbine.util.TurbineException: Error rendering Velocity template: 
null

I verified that newly added WML portlets are not assigned a ClearPortletControl 
control element in the PSML file, as it happens with the default portlets 
(StockQuotes and Weather).

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message