portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luta, Raphael (VUN)" <Raphael.L...@groupvu.Com>
Subject RE: Minor build problems with Jetspeed CVS
Date Fri, 06 Dec 2002 21:10:19 GMT
De : Gary Lawrence Murphy [mailto:garym@canada.com]
>
> Yesterday it worked
> Today it does not
> CVS is like that
> 

Things like this happen but should tyoically not, especially so close to a
release...

> This appears to be a new problem occuring with the plain vanilla CVS
> demo build -- has anyone else seen this or anything like it?
> Yesterday I could build and run the CVS no problem, but after an
> update a few minutes ago, something has broken; what's really odd is
> the way the first line ends with just Lorg/apache/jets
> 
> java.lang.VerifyError: (class: 
> org/apache/jetspeed/services/portaltoolkit/JetspeedPortalToolk
> itService, method: getSet signature: 
> (Lorg/apache/jetspeed/om/profile/Portlets;Lorg/apache/jetspeed
> /services/portaltoolkit/JetspeedPortalToolkitService$VariableI
> nteger;)Lorg/apache/jets
>     at java.lang.Class.forName0(Native Method)
>     at java.lang.Class.forName(Class.java:140)
>     at 
> org.apache.turbine.services.BaseInitableBroker.getInitableInst
> ance(BaseInitableBroker.java:257)
> 

The fact that you get a VerifyError makes me think there's something
rotten in your environment. I sometimes git this kind of errors when
mixing classes compiled by different compilers and used on different
JVM.

I advise you to try a clean checkout and rebuild with a single compiler
and see if this fix your issue.


--
To unsubscribe, e-mail:   <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jetspeed-dev-help@jakarta.apache.org>


Mime
View raw message