portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aurelien Pernoud" <apern...@sopragroup.com>
Subject DBPSML with Oracle and Jetspeed 1.4b1 : Finally got it to work !
Date Wed, 23 Oct 2002 15:52:39 GMT
Hi there,

I was trying to put psml in database. I'm using 1.4b1 and Oracle. I've
followed the "How-to" many times, from the beginning, and it doesn't work
well with... Oracle in fact. Due to the ORA-01465 sql error with BLOB !

Here's what I've tried, several times (with little changes I'll explain
later), without success :

- Modify build.properties and psml.properties to use oracle
- Build jetspeed -> ok
- replace the jar in tomcat with the new one
- run SQL scripts this order :
turbine-oracle (from ext) to use oracle for user as well
security-schema freshly created
dbpsml-schema freshly created
and finally populate

Didn't have any errors.

Then modified the torque.properties in jetspeed to start the import process.
When I come to the portal, I can see the login, then a "Unable to fetch
pane", and here's the log I had :

[Wed Oct 23 17:32:09 CEST 2002] -- INFO -- Running PSMLImporter...
[Wed Oct 23 17:32:09 CEST 2002] -- INFO -- PSML-Man: calculated
resource:user\admin\html\default.psml. Base:
[Wed Oct 23 17:32:10 CEST 2002] -- ERROR -- Error saving
[Wed Oct 23 17:32:10 CEST 2002] -- ERROR -- Error occurred in Database PSML
	Exception:  org.apache.torque.TorqueException: ORA-01465: nombre
hexadécimal incorrect

	Stack Trace follows:
	java.sql.SQLException: ORA-01465: nombre hexadécimal incorrect
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:180)

[Wed Oct 23 17:32:11 CEST 2002] -- INFO -- PSMLImporter completed. Exported
0 profiles

I then saw a thread
with the exact same trouble, so I just tried to change every scripts used
above to modify every BLOB found with a LONG RAW.

In fact the guy was right, all generated scripts (security-schema,
dbpsml-schema) have BLOB inside, and it doesn't work with Oracle.

I first saw that in sql/external there was a psml-db-oracle.sql, which is
fine, but there's no security-schema-oracle, so a default user will use the
one created with Torque (I tried so many combinations I don't remember)

Now it works, but woooooooooow, that was long. Don't know if the trouble is
still there with a nightly build and future 1.4b2, but nothing on the
website mention it right now.

Aurélien Pernoud

To unsubscribe, e-mail:   <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jetspeed-dev-help@jakarta.apache.org>

View raw message