portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13255] New: - Sloppy XML encoding parsing in URLFetcher
Date Thu, 03 Oct 2002 19:16:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13255>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13255

Sloppy XML encoding parsing in URLFetcher

           Summary: Sloppy XML encoding parsing in URLFetcher
           Product: Jetspeed
           Version: 1.4b1
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Miscellaneous
        AssignedTo: jetspeed-dev@jakarta.apache.org
        ReportedBy: matija.mazi@student.fmf.uni-lj.si
                CC: burton@apache.org


In 
org.apache.jetspeed.services.urlmanager.URLFetcher.getReader(URLConnection):
the 
encoding is parsed out by searching for 'encoding="' string; this is really sloppy for serveral

reasons: according to the XML specification single quote may be used instead of double quote

(this is the where I had problems), there may be some whitespace surrounding the '=' (as far
as I 
know), and of course, the encoding attribute should only be used if it appears inside '<?xml'
and 
'?>'.

--
To unsubscribe, e-mail:   <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jetspeed-dev-help@jakarta.apache.org>


Mime
View raw message