portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Golden <ggol...@umich.edu>
Subject FW: DO NOT REPLY [Bug 8979] New: - getID() not working
Date Fri, 10 May 2002 16:49:40 GMT
I'm not sure why this was not sent to the list directly, except maybe
because I assigned the bug to me!

-----Original Message-----
From: bugzilla@apache.org [mailto:bugzilla@apache.org] 
Sent: Friday, May 10, 2002 12:33 PM
To: ggolden@umich.edu
Subject: DO NOT REPLY [Bug 8979] New: - getID() not working


DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8979>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8979

getID() not working

           Summary: getID() not working
           Product: Jetspeed
           Version: 1.3a3-dev / CVS
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Portlet API
        AssignedTo: ggolden@umich.edu
        ReportedBy: ggolden@umich.edu


Portlet.getID() doesn't work reliably under all possible request / caching /

multi-user situations.

Without portlet caching, it seems to always return NULL.

If a portlet's parameters (PSML) were just changed, the next request from
the 
portlet cache gives a Portlet with getID() returning NULL.

--
To unsubscribe, e-mail:   <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jetspeed-dev-help@jakarta.apache.org>


Mime
View raw message