portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9123] New: - Multiple template root feature not working with JSP
Date Wed, 15 May 2002 18:06:35 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9123>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9123

Multiple template root feature not working with JSP

           Summary: Multiple template root feature not working with JSP
           Product: Jetspeed
           Version: 1.3a3-dev / CVS
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Major
          Priority: Other
         Component: JSP
        AssignedTo: jetspeed-dev@jakarta.apache.org
        ReportedBy: mark_orciuch@ngsltd.com


I added another template root located in /jsp folder containing template 
Simple.jsp:

1. Modified jr.props:
services.TemplateLocator.templateRoot=/WEB-INF/templates,/
2. Modified tr.props: services.JspService.templates=/WEB-INF/templates/jsp,/jsp
3. According to debug statements the screen template is found (although
screenJSP is set to /WEB-INF/templates/jsp/screens/Simple.jsp?).
4. Got FileNotFoundException: JSP file not found on
/layouts/html/default.jsp'

I tested it with Velocity and it works fine.

--
To unsubscribe, e-mail:   <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jetspeed-dev-help@jakarta.apache.org>


Mime
View raw message