portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 8980] New: - Jetspeed hangs when reading cached content
Date Fri, 10 May 2002 16:39:49 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8980>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8980

Jetspeed hangs when reading cached content

           Summary: Jetspeed hangs when reading cached content
           Product: Jetspeed
           Version: 1.3a3-dev / CVS
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Cache
        AssignedTo: jetspeed-dev@jakarta.apache.org
        ReportedBy: ggolden@umich.edu


Sometimes, when starting Jetspeed up, if the anon page has a portlet that uses 
cached content, such as an "HTML" portlet showing local file content, as this 
first page is being sent to the browser, jetspeed hangs, the browser waits 
forever for the page, and the jetspeed.log has this as the final entry:

[00:13:31,978 DEBUG] JetspeedTemplatePage: requested template = Home.vm
[00:13:31,990 DEBUG] template exists: /usr/local/jakarta-tomcat-
4.0.3/webapps/chef/WEB-INF/templates/vm/screens/html/Home.vm 
returning /html/Home.vm
[00:13:31,995 DEBUG] JetspeedTemplatePage: calculated template = /html/Home.vm
[00:13:31,997 DEBUG] template exists: /usr/local/jakarta-tomcat-
4.0.3/webapps/chef/WEB-INF/templates/vm/layouts/html/default.vm 
returning /html/default.vm
[00:13:31,997 DEBUG] JetspeedTemplatePage: layoutTemplate is 
finally /html/default.vm
[00:13:32,169 DEBUG] template exists: /usr/local/jakarta-tomcat-
4.0.3/webapps/chef/WEB-INF/templates/vm/navigations/html/top.vm 
returning /html/top.vm
[00:13:33,980 INFO ] Start Initializing service (late): GlobalCacheService
[00:13:33,984 INFO ] Finish Initializing service (late): GlobalCacheService
[00:13:33,985 INFO ] cache miss, object expired: -11949910421013538990

At this point, I must shutdown and restart Jetspeed, sometimes many times 
before it gets past this.

Removeing the cached content portlet from the anon page may help avoid this 
problem.

Jdk 1.3 or 1.4, Tomcat 4.0.3, XP or Mac OSX (Darwin)

--
To unsubscribe, e-mail:   <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jetspeed-dev-help@jakarta.apache.org>


Mime
View raw message