phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Istvan Toth <st...@apache.org>
Subject Re: Unable to connect to HBase 2.2.4
Date Wed, 17 Jun 2020 11:55:51 GMT
Phoenix 5.0 doesn't work with HBase 2.2.

There is no released Phoenix version that works with Hbase 2.2, only the
development version (master branch)  does.


On Wed, Jun 17, 2020 at 12:40 PM Arun J <mail.jak@gmail.com> wrote:

> After installing Phoenix 5.0 with HBase 2.2.4, I am unable to connect
> using sqlline.py or squirrel or through a JDBC Class.
>
> Getting this error
> Caused by: java.io.IOException:
> org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode =
> NoNode for /hbase-unsecure
>
> # Verified all services are running in HBase (HMaster, RegionServer etc)
> # Verified zookeeper is running on localhost:2181
> # Verified server lib in hbase/lib
> # Verified HBase has loaded the driver during starting in its log
>
> Not sure what is missing - how do I further debug - are there any hbase
> config that I can override?  Attached the full stack trace and command line
> snippet.
>
> Appreciate any pointers on whether it is supported and if supported how do
> I go about fixing this.
>
> Java code tried
>
> package conn;
>
> import java.sql.*;
> import java.util.*;
>
> public class PhoenixClient {
>
>     public static void main(String args[]) throws Exception {
>         Connection conn;
>         Properties prop = new Properties();
>         Class.forName("org.apache.phoenix.jdbc.PhoenixDriver");
>         conn =  DriverManager.getConnection("jdbc:phoenix:localhost:2181:/hbase-unsecure");
>
>         if(conn != null){
>             System.out.println("Test Connection Successful:"+conn.toString());
>         }
>     }
> }
>
>

Mime
View raw message