Hi Guanghao Zhang,

The phoenix version that you specify is only used during tests, so it has no effect on the server or client JAR built.
That said, it should compile with any recent phoenix branch, so thank you for the patch. I've already merged it.

Istvan

On Fri, Mar 13, 2020 at 3:52 PM Guanghao Zhang <zghaobac@gmail.com> wrote:
Hi, phoenix team:
      I want to use phoenix query server and my hbase cluster version is 2.2.3. Now the query server was decoupled to a new git repo and only have master branch. I checked the pom and found it's hbase dependency version is 1.4.10 and it's phoenix dependency version is 4.14.2-HBase-1.4. If i am not wrong, it should not compatible with my hbase cluster (hbase 2.2.3 and phoenix 5.1.0-SNAPSHOT)?. I changed some code and build with hbase 2.2.3 and phoenix 5.1.0-SNAPSHOT. If I want contribute the changes to the queryserver repo, I should contribute it to which branch? Thanks.


--
István Tóth | Sr. Software Engineer
stoty@cloudera.com
Cloudera
Cloudera on TwitterCloudera on FacebookCloudera on LinkedIn