I'm evaluating using Phoenix on mapr platform. I am able to get it working via sqlline or java, spark client but having issues with queryserver (exception below).


[mapr@host bin]$ 17/09/09 01:14:18 INFO zookeeper.ClientCnxn: Opening socket connection to server localhost/0:0:0:0:0:0:0:1:2181. Will not attempt to authenticate using SASL (unknown error)

17/09/09 01:14:18 WARN zookeeper.ClientCnxn: Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect

java.net.ConnectException: Connection refused

        at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)

        at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717)

        at org.apache.phoenix.shaded.org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:361)


Here is what I have tried until now.

1.       Mapr zookeeper runs on 5181. I tried changing it to 2181 but then the other services started failing.  

2.       Port redirect from 2181 -> 5181 via iptables.

3.       Also tried changing the port in src java classes and using the update jars but still getting the same error.


Anybody had this issue before? Is queryserver works on mapr? Any suggest?


Any help would be appreciated.  Thanks in advance.


Thanks & Regards,

Pawan Agnihotri

Software Developer, Business Technology Solutions
Valassis Direct Mail, Inc
1 Targeting Center

Windsor CT 06095

Phone: +1 860 298 5520

Cell: +1 860 325 8794

India : +91 775 708 1071