Hi,

We would like to query Phoenix from a Ruby app. We found 2 Ruby connectors for Apache Phoenix but one of them required Java1.5 and other was using Phoenix4.1.
Java1.5 is probably really hard to use in our stack and jdk version upgrade of "ruby java bridge" seems like a very big task.

So, i am leaning towards using Phoenix Query Server now. Since QueryServer is fairly new component, I would like to take feedback from users who are running it in production?

We are using HDP2.3.4(Phoenix4.4). Our workload is not very heavy. We are going to use Query Server strictly for reads, essentially, doing some aggregate queries.

--
Thanks & Regards,
Anil Gupta