phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sumanta Gh <sumanta...@tcs.com>
Subject Getting errors in Phoenix queries with JOIN clause[Phoenix version 3.2.2]
Date Mon, 27 Jul 2015 12:20:09 GMT
Hello,

I'm getting an error (Error: Encountered exception in sub plan [0] execution. (state=,code=0)) with
Apache Phoenix version 3.2.2 while I'm trying to execute a query with INNER JOIN or LEFT OUTER
JOIN or with sub-query.I'm using sqlline.py client from hadoop1/bin directory found under
Phoenix 3.2.2 distribution.In my case only simple queries(without JOIN and sub-query) are
executing successfully.

Please find my environment details as below:

Operating System: Ubuntu 14.04
HBase version: 0.94.18  (on Amazon EMR)
Hadoop version: 1.0.4
Apache Phoenix version: Phoenix 3.2.2
Java: Oracle JDK 7

I have also tried Phoenix 3.3.1 but I'm getting the same error.Could you please help me in
this regard to resolve this issue.If I'm missing anything related the version compatibility
or something else please also let me know.

Regards
Sumanta 
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you



Mime
View raw message