phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Kamil <>
Subject building phoenix with Hadoop2 from CDH
Date Wed, 11 Jun 2014 19:58:14 GMT
I'm trying to run phoenix 3.1 sqlline client against cluster with
hadoop-2.0.0-cdh4.6.0. after building phoenix against hadoop2 profile
seeing this error in sqlline:

at sqlline.SqlLine.main(
Caused by: java.lang.NoSuchMethodError:;)Ljava/io/InputStream;
   at org.apache.hadoop.hbase.ipc.HBaseClient$Connection.setupIOstreams(

14/06/11 19:26:26 INFO
client.HConnectionManager$HConnectionImplementation: getMaster attempt
8 of 14 failed; Could not set up IO Streams

at org.apache.hadoop.hbase.ipc.HBaseClient$Connection.setupIOstreams(

based on other threads such as Phoenix/JDBC becomes unresponsive
<> looks like it's due to
conflict between two different versions of hadoop: hadoop-2.0.0 which comes
with phoenix and hadoop-2.0.0-cdh4.6.0 on the cluster

to fix this I've tried to recompile phoenix with hadoop-2.0.0-cdh4.6.0  by
changing phoenix/pom.xml as shown below and rebuilding hadoop2 profile but
 getting a different error, and looks like it's missing commons-collections
classes, I've tried to add common-collections and hadoop-common jar to
sqlline classpath but still getting this error, any ideas how to fix this?



phoenix/pom.xml changes:

*1. add cloudera repository*





*2. update hadoop.profile  version*

<!-- Hadoop Versions -->



  *  <hadoop-two.version>2.0.0-cdh4.6.0</hadoop-two.version>*

*3. update dependency versions*

<!-- Dependency versions -->


 *   <hbase.version>0.94.15-cdh4.6.0</hbase.version>*


*    <hadoop.version>2.0.0-cdh4.6.0</hadoop.version>*



View raw message