Ah.  I was doing -Dhadoop.profile=2 
I will try that out, thanks!

Abe


On Thu, Feb 27, 2014 at 12:51 PM, Stan Campbell <stan.campbell3@gmail.com> wrote:
I added a dependency to the phoenix core POM for Snappy.. builds happily now.

<dependency>
        <groupId>org.xerial.snappy</groupId>
        <artifactId>snappy-java</artifactId>
        <version>${snappy.version}</version>
      </dependency>

I think I'm using the right profile..

mvn -DskipTests -Dprofile=hadoop-2 package



On Thu, Feb 27, 2014 at 9:46 AM, Abe Weinograd <abe@flonet.com> wrote:
Not sure if you did something.  I pulled latest and still can't build against it.

Thanks,
Abe


On Thu, Feb 27, 2014 at 12:32 PM, Stan Campbell <stan.campbell3@gmail.com> wrote:
Anybody able to build 4.0 against Hadoop2 ?


On Wed, Feb 26, 2014 at 12:51 PM, Jeffrey Zhong <jzhong@hortonworks.com> wrote:
There are some errors building with profile 2.0.  Let me fix it.  

From: Abe Weinograd <abe@flonet.com>
Reply-To: <user@phoenix.incubator.apache.org>
Date: Wednesday, February 26, 2014 6:17 AM
To: <user@phoenix.incubator.apache.org>
Cc: Stan Campbell <stan.campbell3@gmail.com>
Subject: Re: Building 4.0

Thanks Jeffrey.  I did a svn checkout from the tip of the hbase trunk and built off of that and with the 2.0 profile, it wasn't building.  It seems like the build from Jenkins was on the 1.0 profile (default).  I can successfully build that myself, but not with the 2.0 profile.  

Has anyone been able to do this?

Thanks,
Abe


On Tue, Feb 25, 2014 at 6:23 PM, Jeffrey Zhong <jzhong@hortonworks.com> wrote:

Since there are interface changes between 0.96 & 0.98, the Phoenix 4.0 branch can only work on current tip of hbase0.98 and hbase trunk branch. (the changes to make it work on 0.96 should not much  though) or hbase0.98 + HBASE-10486.

-Jeffrey

From: Stan Campbell <stan.campbell3@gmail.com>
Date: Tuesday, February 25, 2014 2:53 PM
To: <user@phoenix.incubator.apache.org>
Cc: Jeffrey Zhong <jzhong@hortonworks.com>
Subject: Re: Building 4.0

Can you point me to the 4.0 repo?

On Feb 25, 2014 2:46 PM, "Mujtaba Chohan" <mujtaba@apache.org> wrote:
4.0 branch builds against latest HBase0.98 but currently not with 0.96. @Jeffrey Zhong

-mujtaba




On Tue, Feb 25, 2014 at 1:27 PM, Abe Weinograd <abe@flonet.com> wrote:
I am having some issues building 4.0.

I built HBase the same way Jenkins is for the 4.0 branch.  When building Phoenix, i get a bunch of Hbase related "cannot find symbol".  I am trying to build for CDH5 (running Hadoop 2.2 and HBase 0.96.1)  

I am building Phoenix with hadoop.profile=2

Anything obvious that I am missing?

Thanks,
Abe


CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to which it is addressed and may contain information that is confidential, privileged and exempt from disclosure under applicable law. If the reader of this message is not the intended recipient, you are hereby notified that any printing, copying, dissemination, distribution, disclosure or forwarding of this communication is strictly prohibited. If you have received this communication in error, please contact the sender immediately and delete it from your system. Thank You.


CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to which it is addressed and may contain information that is confidential, privileged and exempt from disclosure under applicable law. If the reader of this message is not the intended recipient, you are hereby notified that any printing, copying, dissemination, distribution, disclosure or forwarding of this communication is strictly prohibited. If you have received this communication in error, please contact the sender immediately and delete it from your system. Thank You.