phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Rodríguez Hortalá <>
Subject Offending class: javax/servlet/Servlet.class using Phoenix JDBC from Saiku
Date Wed, 05 Feb 2014 16:55:44 GMT
Hi list!,

I've built phoenix following the instructions of in a Cloudera Quickstart
VM for CDH 4.4.0 and I've obtained the following jars:


Then I have copied phoenix-core-3.0.0-SNAPSHOT.jar into /usr/lib/hbase/lib/
and restarted HBase and I'm able to access to HBase tables and create new
HBase tables with, which means phoenix-3.0.0-SNAPSHOT-client.jar
is working ok. But now I would like to use Phoenix as a source for a saiku
server I'm running in the host machine for the Cloudera VM, which is a
windows 8. To do that, following,
I have copied the client phoenix-3.0.0-SNAPSHOT-client.jar into
saiku-server\tomcat\webapps\saiku\WEB-INF\lib for the Saiku installation
and restarted Saiku, and here is where the problem occours, as tomcats
rejects phoenix-3.0.0-SNAPSHOT-client.jar with the following message at

feb 05, 2014 4:20:59 P.M. org.apache.catalina.loader.WebappClassLoader
- jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class:
feb 05, 2014 4:21:17 P.M. com.sun.jersey.api.core.PackagesResourceConfig
INFO: Scanning for root resource and provider classes in the packages:

After some searching I've found that the problem is that
javax.servlet.Servlet.class is already defined in some other jar, so tomcat
rejects any jar containing another definition of the same class. I've tried
using the other client jars for phoenix by the class
org.apache.phoenix.jdbc.PhoenixDriver seems to be missing in those other

[cloudera@localhost target]$ jar tf
phoenix-3.0.0-SNAPSHOT-client-without-hbase.jar | grep -i phoenix
[cloudera@localhost target]$ jar tf
phoenix-3.0.0-SNAPSHOT-client-minimal.jar | grep -i phoenix
[cloudera@localhost target]$

I've also tried deleting that javax folder from the file
phoenix-3.0.0-SNAPSHOT-client.jar, but it doesn't work anyway. I would
appreciate any idea for solving this

Thanks in advance,


Juan Rodríguez Hortalá <>

View raw message