phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wijesinghe, Dimitri" <>
Subject Issue Creating Indexes in Phoenix
Date Thu, 30 Jan 2014 17:23:36 GMT

I am trying to create an index for a table with about 100M records, with 10
SALT buckets across a five-node cluster. Running HBase 0.94.12 and Phoenix

When I issue the following command in I get the error message
below after a roughly 10-minute wait.

0: jdbc:phoenix:C-Master,C-Slave,C-Slave2,C-S> CREATE INDEX idx ON

Error:  (state=08000,code=101)

I believe this is just the general Phoenix error code so I am not what the
exact problem is. I had previously tried this operation on a 1M record
table (the 100M table is basically a 100 copies of the previous table with
different primary keys). The indexing on the 1M table worked perfectly.

Any help would be greatly appreciated as un-indexed operations on the
cluster are now taking a fairly significant amount of time.


*Dimitri Wijesinghe*

*iVantage Health Analytics*®

Web Developer

300 Chestnut Street, Suite 101 | Needham, MA 02492

direct: 781-247-20*91* | office: 781-499-5287

email: |<>

View raw message