perl-docs-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@apache.org
Subject cvs commit: modperl-docs/src/docs/2.0/user/install install.pod
Date Sat, 22 Nov 2003 21:57:11 GMT
stas        2003/11/22 13:57:11

  Modified:    src/docs/2.0/user/install install.pod
  Log:
  specify CPAN modules prerequisites for the test suite and users code
  
  Revision  Changes    Path
  1.50      +22 -0     modperl-docs/src/docs/2.0/user/install/install.pod
  
  Index: install.pod
  ===================================================================
  RCS file: /home/cvs/modperl-docs/src/docs/2.0/user/install/install.pod,v
  retrieving revision 1.49
  retrieving revision 1.50
  diff -u -u -r1.49 -r1.50
  --- install.pod	28 Oct 2003 20:22:24 -0000	1.49
  +++ install.pod	22 Nov 2003 21:57:11 -0000	1.50
  @@ -68,6 +68,28 @@
   
   =back
   
  +=item * CPAN Perl Modules
  +
  +The mod_perl 2.0 test suite has several requirements on its own. If
  +you don't satisfy them, the tests depending on these requirements will
  +be skipped, which is OK, but you won't get to run these tests and
  +potential problems, which may exhibit themselves in your own code,
  +could be missed. We don't require them from C<Makefile.PL>, which
  +could have been automated the requirements installation, in order to
  +have less dependencies to get mod_perl 2.0 installed.
  +
  +Also if your code uses any of these modules, chances are that you will
  +need to use at least the version numbers listed here.
  +
  +=over
  +
  +=item CGI.pm 3.01
  +
  +=item Compress::Zlib 1.09
  +
  +=back
  +
  +
   =back
   
   
  
  
  

---------------------------------------------------------------------
To unsubscribe, e-mail: docs-cvs-unsubscribe@perl.apache.org
For additional commands, e-mail: docs-cvs-help@perl.apache.org


Mime
View raw message