mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Rukletsov <ruklet...@gmail.com>
Subject Re: Review Request 68360: Removed Principal object from ObjectApprovers class.
Date Thu, 16 Aug 2018 12:44:52 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68360/#review207403
-----------------------------------------------------------


Fix it, then Ship it!





src/common/http.hpp
Line 206 (original), 206 (patched)
<https://reviews.apache.org/r/68360/#comment290792>

    Maybe you can find a better name? Maybe `principalName`? In `Principal` it is called `value`,
but I doubt `principalValue` is descriptive enough.



src/common/http.hpp
Line 239 (original), 239 (patched)
<https://reviews.apache.org/r/68360/#comment290793>

    `const`?


- Alexander Rukletsov


On Aug. 16, 2018, 12:33 p.m., Benno Evers wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/68360/
> -----------------------------------------------------------
> 
> (Updated Aug. 16, 2018, 12:33 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov and Alexander Rojas.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> After creation on an `ObjectApprovers` instance, the principal
> is only required for providing meaningful log messages.
> 
> This commit encodes that at the type system by storing the principal
> as a string as opposed to a `Principal` object.
> 
> 
> Diffs
> -----
> 
>   src/common/http.hpp 0901a5528b3c383e3e391a3ac1571fd0fd544998 
> 
> 
> Diff: https://reviews.apache.org/r/68360/diff/1/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Benno Evers
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message