mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jie Yu <yujie....@gmail.com>
Subject Re: Review Request 62903: Added the `UPDATE_TOTAL_RESOURCES` call.
Date Tue, 17 Oct 2017 21:50:56 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/62903/#review188396
-----------------------------------------------------------




include/mesos/resource_provider/resource_provider.proto
Lines 94 (patched)
<https://reviews.apache.org/r/62903/#comment265385>

    Given that this not only reports total resources, but also reports pending/unacked opeations,
maybe use a different name for this? E.g., `UpdateState`?



src/resource_provider/manager.cpp
Line 310 (original), 316 (patched)
<https://reviews.apache.org/r/62903/#comment265387>

    Looks like we decoupled the (re)registration from the resource reporting. We probably
need to distinguish these two states in the RP manager. For example:
    
    ```
    CONNECTED; // This means the PR is subscribed, but not yet report the state yet
    READY; // This means the RP is subscribed, and reported the state already.
    ```
    
    No need to address in this review. This comment is just for future reference once we start
to implement RP manager.



src/resource_provider/manager.cpp
Lines 347-353 (patched)
<https://reviews.apache.org/r/62903/#comment265382>

    No need for ID injection. The RP in this case is responsible for injecting ID.



src/tests/resource_provider_validation_tests.cpp
Lines 85 (patched)
<https://reviews.apache.org/r/62903/#comment265389>

    Change the name?


- Jie Yu


On Oct. 17, 2017, 8:50 p.m., Chun-Hung Hsiao wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/62903/
> -----------------------------------------------------------
> 
> (Updated Oct. 17, 2017, 8:50 p.m.)
> 
> 
> Review request for mesos, Benjamin Bannier, Jie Yu, and Jan Schlicht.
> 
> 
> Bugs: MESOS-8107
>     https://issues.apache.org/jira/browse/MESOS-8107
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Now a resource provider can first `SUBSCRIBE` to the resource provider
> manager without resources to get its ID, then use the ID to locate the
> checkpoints for recovery and prepare persistent work directory, and then
> update its total resources later through `UPDATE_TOTAL_RESOURCE`.
> 
> This patch also renames `UPDATE` to `UPDATE_OPERATION_STATUS`.
> 
> 
> Diffs
> -----
> 
>   include/mesos/resource_provider/resource_provider.proto f5a9073075327019fd133bd51265f695ef464845

>   include/mesos/v1/resource_provider/resource_provider.proto e5cbede5b6e57a8641fca1ebfee5454f292cc24c

>   src/resource_provider/manager.cpp 31fcb789f5ab907511e868c374c49f7457a33ed3 
>   src/resource_provider/validation.cpp d2927227f60ab0d4ae2481ad73a31ee444b48ee0 
>   src/tests/resource_provider_manager_tests.cpp ca49e1f0203494fc8b4a4507c33e5a3885a14a59

>   src/tests/resource_provider_validation_tests.cpp f182bff4670318e9de22c2915c5dbb423a74ad6c

> 
> 
> Diff: https://reviews.apache.org/r/62903/diff/6/
> 
> 
> Testing
> -------
> 
> make tests
> 
> 
> Thanks,
> 
> Chun-Hung Hsiao
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message