mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mesos Reviewbot <revi...@mesos.apache.org>
Subject Re: Review Request 62512: Disabled RestartSlaveRequireExecutorAuthentication test on Windows.
Date Sat, 23 Sep 2017 03:49:59 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/62512/#review186046
-----------------------------------------------------------



Patch looks great!

Reviews applied: [62508, 62509, 62510, 62511, 62512]

Passed command: export OS='ubuntu:14.04' BUILDTOOL='autotools' COMPILER='gcc' CONFIGURATION='--verbose'
ENVIRONMENT='GLOG_v=1 MESOS_VERBOSE=1'; ./support/docker-build.sh

- Mesos Reviewbot


On Sept. 22, 2017, 7:52 p.m., Andrew Schwartzmeyer wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/62512/
> -----------------------------------------------------------
> 
> (Updated Sept. 22, 2017, 7:52 p.m.)
> 
> 
> Review request for mesos, John Kordich, Joseph Wu, and Till Toenshoff.
> 
> 
> Bugs: MESOS-7992
>     https://issues.apache.org/jira/browse/MESOS-7992
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This test became enabled when building with OpenSSL on Windows. The
> first part of the test failed because of the use of the Linux command
> `cat` to launch an indefinitely running task. This was fixed using
> `more` on Windows. However, the test subsequently fails when recoverying
> to due "incompatible agent info", an existing bug: MESOS-7604.
> 
> 
> Diffs
> -----
> 
>   src/tests/slave_tests.cpp e9bcfefd52e1e99a7a5877b2e7c30af958ca1723 
> 
> 
> Diff: https://reviews.apache.org/r/62512/diff/1/
> 
> 
> Testing
> -------
> 
> This represents testing for the whole chain.
> 
> Built on Windows 10 with OpenSSL 1.0.2L from [Shining Light Productions](https://slproweb.com/products/Win32OpenSSL.html),
configuring with `-DENABLE_LIBEVENT=ON -DENABLE_SSL=ON -DOPENSSL_ROOT_DIR="C:\OpenSSL-Win64"`.
Ran `stout-tests`, `libprocess-tests`, and `mesos-tests`, all passing except for this disabled
one. Verified new SSL tests were enabled.
> 
> Built on CentOS 7 with CMake `-DENABLE_LIBEVENT=ON -DENABLE_SSL=ON`, all tests passed.
> 
> ~~Built on CentOS 7 with Autotools, however, I'm running into some seemingly flaky tests.~~
> 
> I don't seem to have a reliable Autotools build with SSL at all, even on `master`.
> 
> 
> Thanks,
> 
> Andrew Schwartzmeyer
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message