mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Peach <jpe...@apache.org>
Subject Review Request 59554: Rename the `--allowed_capabilities` flag to `--effective_capabilities`.
Date Wed, 24 May 2017 23:46:21 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/59554/
-----------------------------------------------------------

Review request for mesos, Jie Yu and Jiang Yan Xu.


Bugs: MESOS-7477
    https://issues.apache.org/jira/browse/MESOS-7477


Repository: mesos


Description
-------

Since the `--allowed_capabilities` flag was being used to actually
grant capabilities, rename it to `--effective_capabilities` which better
conveys the intention and semantics of this flag.


Diffs
-----

  docs/configuration.md 59e1bbe7502c7f55fb3fb3167ccdccc1294e6db7 
  docs/linux_capabilities.md b588aff6842a14bbf7ff5c35931cac61f9019805 
  src/slave/containerizer/mesos/isolators/linux/capabilities.cpp 60d22aa877c1ab62a08222e5efe8800e337684da

  src/slave/flags.hpp b66995630f89dfb95a6d0cf66efc5d7590e90cbc 
  src/slave/flags.cpp 0c8276e425a6a7d22ee68edc6cc25b331635ec44 
  src/tests/containerizer/linux_capabilities_isolator_tests.cpp 40376a03fdb8f931f8d3f83b1c3fa6207e02c1d1



Diff: https://reviews.apache.org/r/59554/diff/1/


Testing
-------

make check (Fedora 25)


Thanks,

James Peach


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message