mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joseph Wu <jos...@mesosphere.io>
Subject Re: Review Request 54985: Fixed the CMake test target in mesos.
Date Thu, 22 Dec 2016 18:42:12 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/54985/#review159993
-----------------------------------------------------------


Ship it!




Ship It!

- Joseph Wu


On Dec. 22, 2016, 8:41 a.m., Michael Park wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/54985/
> -----------------------------------------------------------
> 
> (Updated Dec. 22, 2016, 8:41 a.m.)
> 
> 
> Review request for mesos, Alex Clemmer and Joseph Wu.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> When the test is executed via `ctest` rather than `make check`, we run
> into the following error for Mesos:
> 
> ```
> test 3
>   Start 3: MesosTests
>   Could not find executable ./mesos-tests
>   Looked in the following places:
>   ./mesos-tests
>   ./mesos-tests
>   ./Release/mesos-tests
>   ./Release/mesos-tests
>   ./Debug/mesos-tests
>   ./Debug/mesos-tests
>   ./MinSizeRel/mesos-tests
>   ./MinSizeRel/mesos-tests
>   ./RelWithDebInfo/mesos-tests
>   ./RelWithDebInfo/mesos-tests
>   ./Deployment/mesos-tests
>   ./Deployment/mesos-tests
>   ./Development/mesos-tests
>   ./Development/mesos-tests
> 
>   3: Test command:
>   Unable to find executable: ./mesos-tests
>   3/3 Test #3: MesosTests .......................***Not Run   0.00 sec
> 
>   67% tests passed, 1 tests failed out of 3
> 
>   Total Test time (real) =   1.21 sec
> 
>   The following tests FAILED:
>       3 - MesosTests (Not Run)
> Errors while running CTest
> ```
> 
> It turns out that the issue lies in the fact that we don't use the
> executable name directly in `add_test`, but rather have `./` prepended
> to the comand. This patch simply removes the unnecessary `./`.
> 
> 
> Diffs
> -----
> 
>   src/tests/CMakeLists.txt 731d58c5e45e1e5f2f47155ebe556a97fb443044 
> 
> Diff: https://reviews.apache.org/r/54985/diff/
> 
> 
> Testing
> -------
> 
> Compiled and tested with `cmake`, via `make check` and `ctest`.
> 
> 
> Thanks,
> 
> Michael Park
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message