lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shad Storhaug <>
Subject RE: Build error on LuceneDocsPlugin: target "pack" does not exist
Date Mon, 08 Jul 2019 20:37:01 GMT

The Lucene.Net.Tests project has ~3400 tests in it. What I am seeing on the command line is
a fatal crash followed by a report with significantly fewer tests included in it. But it is
inconsistent - sometimes it will fail after about 900 tests and other times it will fail after
about 2900.

So far, I have gone back to the last release tag, pinned to the last known SDK that was used
in global.json (which was 2.0.3), and found that the test run seems to complete there. It
also completed with a newer SDK on that commit.

Going forward to the HEAD of master, the test run for .netcoreapp2.0 fails on the 2.0.3 SDK.
I am still hunting for the commit that causes the difference, but there doesn't seem to be
very many commits between those points that changed any code.

The failure is really obvious if you run them in Visual Studio 2017. The status bar at the
bottom will indicate an unhandled exception, and if you check the Test Output you can see
the message:

[7/9/2019 1:23:16 AM Error] The active Tests Run was aborted.

Unfortunately, there usually isn't anything helpful in there indicating which test caused
the crash. Going forward, I am happy to see there is a --blame switch on the SDK which should
help for this, but for the moment I am trying to rule out variables by sticking with the last
known SDK that works.


-----Original Message-----
From: Aaron Meyers <> 
Sent: Tuesday, July 9, 2019 1:54 AM
Subject: RE: Build error on LuceneDocsPlugin: target "pack" does not exist

Thanks all -- I worked around this by adding a dummy "pack" target to the LuceneDocsPlugin
csproj which I inadvertently included in my PR for strong naming (will fix that).

I tried running the tests (using build -t) on Saturday and hit a lot of failed test cases
across the set of projects. It does seem like the test run completed though as I got some
test result XML files with passed and failed cases. So this seems to be a different result
than what Shad is hitting below. I have .NET Core 3.0 preview installed as well as multiple
.NET Core 2.x SDKs; I forced a 2.x SDK for Lucene.Net using the global.json file.

-----Original Message-----
From: Shad Storhaug <>
Sent: Monday, July 8, 2019 3:40 AM
Subject: RE: Build error on LuceneDocsPlugin: target "pack" does not exist


I am working on a different approach for this by setting the IsPackable MSBuild property to
false by default globally and using the solution file to do the pack rather than looping through
each project file.

I would have pushed it already (along with some other fixes), but now the test runner is fatally
crashing on .NET Core 2.x when testing Lucene.Net.dll. Still investigating.


-----Original Message-----
From: Shannon Deminick <>
Sent: Monday, July 8, 2019 2:00 PM
Cc: Thomas Mathew <>
Subject: Re: Build error on LuceneDocsPlugin: target "pack" does not exist

PR is here;;sdata=DdOLa%2FZ5ZyurrpLTo1jwVD1MSDbVuKOwRvLuw6J9k%2B8%3D&amp;reserved=0

On Mon, Jul 8, 2019 at 4:51 PM Shannon Deminick <> wrote:

> Found the issue, it's in the build.ps1 on line 199:
> $packages = Get-ChildItem -Path "$source_directory\**\*.csproj" 
> -Recurse | ? {
> which is getting all csproj when it needs to ignore the 
> LuceneDocsPlugins one. I'll send a PR for it soon.
> On Mon, Jul 8, 2019 at 4:40 PM Shannon Deminick <>
> wrote:
>> Hi Aaron,
>> I just ran the build.bat locally here and at the very end I get the 
>> same error. TBH i don't think i've actually run this build file 
>> before. This project is purely to build the documentation suite so 
>> maybe its accidentally getting included in the main build script.
>> I'll see if i can find something obvious.
>> Shannon
>> On Sat, Jul 6, 2019 at 8:16 AM Aaron Meyers 
>> <> wrote:
>>> Hi all,
>>> I'm trying to build the current Lucene.Net sources locally and I'm 
>>> running into the following build error:
>>> C:\Data\github\lucenenet\src\docs\LuceneDocsPlugins\LuceneDocsPlugin
>>> s\LuceneDocsPlugins.csproj
>>> : error MSB4057: The targ
>>> et "pack" does not exist in the project.
>>> Error: 7/5/2019 3:00:22 PM:
>>>  +                 ~~~~~& dotnet.exe pack $project --configuration
>>> $Configuration --output $nuget_package_directory --no -build 
>>> --include.symbols /p:PackageVersion=$packageVersion
>>> I've poked around a little bit and haven't figured out what is going 
>>> on
>>> - has anyone else run into this?
>>> My machine has multiple versions of VS (2015/2017/2019) and .NET 
>>> Core SDKs (2.0 through 3.0 preview) so it might have something to do with that.
>>> It was trying to build using the 3.0 preview SDK which overrode with 
>>> global.json in the lucenenet repo root but no effect on this build error.
>>> Thanks!
>>> Aaron Meyers
>>> Principal Software Engineer
>>> Microsoft Power BI
View raw message