lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prescott Nasser <>
Subject RE: Issue with ICU4NET reference
Date Wed, 14 Dec 2016 23:44:09 GMT
People are working on it - we have the pre-release DLL's up on our myget feed - they are very

From: Monica Black []
Sent: Wednesday, December 14, 2016 3:16 PM
To: Prescott Nasser <>
Subject: Re: Issue with ICU4NET reference

Hi Prescott.

You are a life-saver!  I just assumed they were necessary, and I'd just gone to a lot of trouble
to make a custom Analyzer the other day.  I had no issues until trying to wrap it in a web
service, and I don't make those very often, so I thought it was just me until I reviewed the
comments on site.

Do you know the future of the project?  Why isn't anyone working on it?  It's really a great
tool.  I'd use the Java library directly, but it looked complicated to try to make it accessible
to a c# solution.


From: Prescott Nasser <<>>
Sent: December 14, 2016 7:02 PM
Subject: RE: Issue with ICU4NET reference

Hey Monica -

I think it's a known issue (not sure if it's been resolved).

A solution from earlier email messages regarding this:

For the time being, a solution that worked for me was to remove the references to ICU4NET
and ICU4NET.Extensions from my project and delete the file links to the accompanying DLLs.
Your code will still compile and run as long as you don't reference the Thai Analyzer in Lucene.Net.Analysis.Common.
Then just deploy your code to the Webserver and it will work without the error message.
Please be aware that this is only a workaround.

Let us know if that works for you


-----Original Message-----
From: Monica Black []
Sent: Wednesday, December 14, 2016 2:56 PM
Subject: Issue with ICU4NET reference


I've built a library using Lucene.NET 4.8.  Now I'm trying to wrap that library in a web service,
but I keep getting a dependency error on the ICU4NET.dll.  I've tried to make sure everything
is targeting .NET Framework 4.5.1, and that I'm not missing any references, but I can't get
this web service to work as soon as add either my library or just the ICU4NET.dll alone. 
Can someone help me fix this?



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message