lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Costantino <>
Subject [Lucene.Net] Azure Library for Lucene Help...
Date Wed, 03 Aug 2011 01:01:06 GMT
Hey everyone,

*Has anyone had any success with the Azure Library for Lucene?*

I've got search working perfectly with the FSDirectory.  Everything works
great in UnitTests with the RAMDirectory.  However, as soon as I replace the
FSDirectory with the Azure Directory I start getting file not found
exceptions whenever I try to update the index.  I can successfully create
the initial index and search against it but as soon as I try to update index
items, I start getting the file not found exceptions.

*My Architecture:*
1) Separate searcher and index writer.
2) The index writer is a singleton.
3) The searcher is cached for a minimum of 2 minutes.  After the two minutes
the searcher recycles only when updates have been made to the index,
otherwise it caches itself again for 2 minutes.

*What I've Tried Technically:
*1) I validated everything works fine with the FSDirectory.
2) I validated everything works great in UnitTests.  (I've been unable to
replicate the File Not Found exception with unit tests against the Azure
3) I downgraded my Lucene library to 2.3.1 from 2.9.2 since the Azure
Library was originally distributed with 2.3.1.
**Where I've Tried to Get Help:*
1) I posted to the Azure Library FAQ to ask for help
2) I posted to StackOverflow to ask for help
(No responses on either yet)

*What I'm Going to Try Next:* I'm considering developing my own, simpler,
version of the AzureDirectory, but I'm sure this will be a larger effort
than I really want to bite off.  Since I'm not a Lucene expert I'm sure I'll
run into unforeseen issues with concurrency, performance, or something
completely out of left field.

*Why I'm Desperate:*
This is the last feature I need to get working before we release the
product.  I invested a ton of time learning and getting Lucene to work
exactly as we need but right at the end of the development effort I ran into
this issue.  (Granted, I should have tested this library much much much
earlier...  Lesson learned on that front)

Any suggestions?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message