lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Thompson <>
Subject RE: Sharpen setup
Date Mon, 14 Feb 2011 00:35:25 GMT
I'm using Eclipse 3.4.2 (ganymede-SR2) for Java EE. You need a Java EE
edition to build plugins. I haven't tried the Helios versions.

The repository is SVN not CVS so you need an SVN plugin (regular windows
TortoiseSVN had some problems). I use Subclipse
and that gives you the option new project -> from SVN

Then you can export as a Plug-in and put the resulting jars in the /plugins
folder under eclipse.

Next you checkout a version of java lucene (again with subclipse) and you
will need to setup the .project and .classpath files correctly. Here is a
copy of mine for reference:
<?xml version="1.0" encoding="UTF-8"?>

<?xml version="1.0" encoding="UTF-8"?>
	<classpathentry kind="src" path="src/java"/>
	<classpathentry kind="src" path="src/demo"/>
	<classpathentry kind="src" path="src/test"/>
	<classpathentry kind="con"
	<classpathentry kind="lib" path="lib/junit-3.8.2.jar"/>
	<classpathentry kind="lib" path="lib/servlet-api-2.4.jar"/>
	<classpathentry kind="output" path="bin"/>

I use Ant to run sharpen and you can find my Ant scripts as well as the
patches I made for sharpen and preprocessing in my last uploaded package


-----Original Message-----
From: Prescott Nasser [] 
Sent: Sunday, February 13, 2011 2:12 PM
Subject: Sharpen setup

Hey all,
I'm looking for some help setting up sharpen. I haven't done java
development in probably close to 8 years and my tooling knowledge is
incredibly out of date.
I grabbed Eclipse IDE for Java Developers (Version: Helios Service Release 1
Build id: 20100917-0705) and was looking at documentation for sharpen
html/Content/sharpen/how_to_setup_sharpen.html) and

Following the first link, I pulled down the latest sharpen from their
repository, and then imported the project. It then says to export as a
Plug-in - but I don't have that option. Also, eclipse is giving me errors
about org.eclipse not being found.
Following the second link, it says to add a new project -> from CVS.
However, ecplise won't even retrieve the packages from their repo. I've
tried all the options (ext, extssh, pserver, pserverssh) and I get login
errors from the later 3, an a general ext error when selecting that option.
Does anyone have experience setting this up?

View raw message