kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ij...@apache.org
Subject [kafka] branch 2.5 updated: KAFKA-12790: Remove SslTransportLayerTest.testUnsupportedTlsVersion (#10922)
Date Mon, 28 Jun 2021 13:17:19 GMT
This is an automated email from the ASF dual-hosted git repository.

ijuma pushed a commit to branch 2.5
in repository https://gitbox.apache.org/repos/asf/kafka.git


The following commit(s) were added to refs/heads/2.5 by this push:
     new 66fca65  KAFKA-12790: Remove SslTransportLayerTest.testUnsupportedTlsVersion (#10922)
66fca65 is described below

commit 66fca651bedcc2573940d08aefb3c3f03d5762f5
Author: Ismael Juma <ismael@juma.me.uk>
AuthorDate: Sun Jun 27 14:15:19 2021 -0700

    KAFKA-12790: Remove SslTransportLayerTest.testUnsupportedTlsVersion (#10922)
    
    Support for TLS 1.0/1.1 was disabled in recent versions of Java 8/11
    and all versions of 16 causing this test to fail.
    
    It is possible to make it work by updating the relevant security property,
    but it has to be done before the affected classes are loaded and it can
    not be disabled after that. Given the low value of the test, we remove
    it.
    
    Reviewers: Rajini Sivaram <rajinisivaram@googlemail.com>, Luke Chen <showuon@gmail.com>
---
 .../apache/kafka/common/network/SslTransportLayerTest.java   | 12 ------------
 1 file changed, 12 deletions(-)

diff --git a/clients/src/test/java/org/apache/kafka/common/network/SslTransportLayerTest.java
b/clients/src/test/java/org/apache/kafka/common/network/SslTransportLayerTest.java
index 126af6e..fc90c39 100644
--- a/clients/src/test/java/org/apache/kafka/common/network/SslTransportLayerTest.java
+++ b/clients/src/test/java/org/apache/kafka/common/network/SslTransportLayerTest.java
@@ -592,18 +592,6 @@ public class SslTransportLayerTest {
     }
 
     /**
-     * Tests that connections cannot be made with unsupported TLS versions
-     */
-    @Test
-    public void testUnsupportedTLSVersion() throws Exception {
-        sslServerConfigs.put(SslConfigs.SSL_ENABLED_PROTOCOLS_CONFIG, Arrays.asList("TLSv1.2"));
-        server = createEchoServer(SecurityProtocol.SSL);
-
-        checkAuthentiationFailed("0", "TLSv1.1");
-        server.verifyAuthenticationMetrics(0, 1);
-    }
-
-    /**
      * Tests that connections cannot be made with unsupported TLS cipher suites
      */
     @Test

Mime
View raw message