kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rha...@apache.org
Subject [kafka] branch 2.1 updated: KAFKA-7489: Backport removal of 0.9 compatibility checks from ConnectDistributedTest (#8035)
Date Wed, 05 Feb 2020 15:52:43 GMT
This is an automated email from the ASF dual-hosted git repository.

rhauch pushed a commit to branch 2.1
in repository https://gitbox.apache.org/repos/asf/kafka.git


The following commit(s) were added to refs/heads/2.1 by this push:
     new dbb2c60  KAFKA-7489: Backport removal of 0.9 compatibility checks from ConnectDistributedTest
(#8035)
dbb2c60 is described below

commit dbb2c60140eba33a39d51bf951d18065c6fdf836
Author: Greg Harris <gregh@confluent.io>
AuthorDate: Wed Feb 5 07:47:29 2020 -0800

    KAFKA-7489: Backport removal of 0.9 compatibility checks from ConnectDistributedTest (#8035)
    
    (#7023) exposed an incompatibility between Kafka <=0.9 and Connect >0.9,
    in which the broker does not recognize a request for ApiVersions.
    For trunk and 2.4, this test case was removed rather than the issue addressed.
    This effectively backports the other half of (#7023) which was left out of (#7791).
    
    Signed-off-by: Greg Harris <gregh@confluent.io>
    
    Author: Greg Harris <gregh@confluent.io>
    Reviewers: Randall Hauch <rhauch@gmail.com>, Andrew Choi <andchoi@linkedin.com>
---
 tests/kafkatest/tests/connect/connect_distributed_test.py | 1 -
 1 file changed, 1 deletion(-)

diff --git a/tests/kafkatest/tests/connect/connect_distributed_test.py b/tests/kafkatest/tests/connect/connect_distributed_test.py
index ac2472c..6b5494d 100644
--- a/tests/kafkatest/tests/connect/connect_distributed_test.py
+++ b/tests/kafkatest/tests/connect/connect_distributed_test.py
@@ -509,7 +509,6 @@ class ConnectDistributedTest(Test):
     @parametrize(broker_version=str(LATEST_0_10_2), auto_create_topics=False, security_protocol=SecurityConfig.PLAINTEXT)
     @parametrize(broker_version=str(LATEST_0_10_1), auto_create_topics=False, security_protocol=SecurityConfig.PLAINTEXT)
     @parametrize(broker_version=str(LATEST_0_10_0), auto_create_topics=True, security_protocol=SecurityConfig.PLAINTEXT)
-    @parametrize(broker_version=str(LATEST_0_9), auto_create_topics=True, security_protocol=SecurityConfig.PLAINTEXT)
     def test_broker_compatibility(self, broker_version, auto_create_topics, security_protocol):
         """
         Verify that Connect will start up with various broker versions with various configurations.



Mime
View raw message