juneau-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Blackmon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JUNEAU-61) Move org.apche.juneau.remoteable package to rest.client project.
Date Sat, 12 Aug 2017 17:17:00 GMT

    [ https://issues.apache.org/jira/browse/JUNEAU-61?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16124642#comment-16124642

Steve Blackmon commented on JUNEAU-61:

Would it be crazy to merge these packages such that the same annotation is used when declaring
an interface as remote-able, and when declaring an interface to bind a rest proxy?

Presumably the remote server code and the rest proxy code would have the context to decide
which implementation logic to use, which could be pulled over into protected / prefixed or
otherwise internal classes, but implementers would no longer need to pick the right annotation

> Move org.apche.juneau.remoteable package to rest.client project.
> ----------------------------------------------------------------
>                 Key: JUNEAU-61
>                 URL: https://issues.apache.org/jira/browse/JUNEAU-61
>             Project: Juneau
>          Issue Type: Bug
>          Components: Code
>    Affects Versions: 6.3.2
>            Reporter: James Bognar
> I'm noticing that it's easy to make coding mistakes by using the wrong annotations on
the remoteable and rest servlet classes and methods.  For example, it's easy to use org.apache.juneau.remotable.Query
when you meant to use org.apach.juneau.rest.annotation.Query.
> Moving the org.apache.juneau.remoteable package into the rest-client package should help
somewhat with this problem.  There's still an issue that juneau-all includes both sets of
packages, so it's still easy to make a mistake.
> Another option may be to add "C" prefixes to each of the client-side annotations:
> e.g. @CQuery, @CFormData, @CPath, and maybe "S" prefixes on the server-side annotations:
 @SQuery, @SFormData, @SPath.  That looks really ugly though.

This message was sent by Atlassian JIRA

View raw message