juneau-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Bognar <james.bog...@salesforce.com>
Subject Re: Workspace errors.
Date Tue, 09 Aug 2016 17:23:42 GMT
I fixed the issue by adding juneau-core as a dependency in those projects.
My workspace is free of errors and I'm able to build from the root project.

I also renamed all the testcases.

On Tue, Aug 9, 2016 at 12:10 PM, John D. Ament <johndament@apache.org>
wrote:

> Are you building juneau (e.g. the equivalent of mvn clean install)?
>
>
> John
>
> On Tue, Aug 9, 2016 at 12:06 PM James Bognar <james.bognar@salesforce.com>
> wrote:
>
> > I fixed all the errors except for two.  Both
> > org.apache.juneau.microservice.template and org.apache.juneau.distrib
> have
> > this failure and I don't know why...
> >
> > Missing artifact
> > org.apache.juneau:juneau-core:jar:6.0.0-incubating-SNAPSHOT
> > pom.xml /org.apache.juneau.distrib line 16 Maven Dependency Problem
> >
> > FYI....the template project is not supposed to be built.  It's meant to
> be
> > a starting-point project that developers can import into their workspace
> to
> > create a microservice project.  The contents of the project really just
> > need to be zipped up.  Then there's the question of whose pom.xml that
> is.
> > Is it ours for creating the zip or theirs for creating their
> microservice?
> >
> >
> >
> >
> >
> > On Tue, Aug 9, 2016 at 10:27 AM, John D. Ament <johndament@apache.org>
> > wrote:
> >
> > > On Tue, Aug 9, 2016 at 10:20 AM James Bognar <
> > james.bognar@salesforce.com>
> > > wrote:
> > >
> > > > I deleted and re-extracted the projects from Git into my Eclipse
> > > workspace
> > > > to pick up the project name changes.
> > > >
> > > > It's complaining about the classpath entry because that path doesn't
> > > > initially exist.  If I run the POM, it generates that folder and the
> > > > problem goes away.  But is that a valid entry?  A source entry
> pointing
> > > to
> > > > a location under target?
> > > >
> > >
> > > Nope, that doesn't make sense.
> > >
> > >
> > > >
> > > > I'm also seeing these errors....
> > > >
> > > >
> > > That should have been fixed.  All incubator projects include
> "incubating"
> > > in the release name.  I fixed that in the pom files.  Its possible I
> > missed
> > > juneau-server-test, but doesn't look like it from the pom file:
> > > https://github.com/apache/incubator-juneau/blob/master/
> > > org.apache.juneau.server.test/pom.xml#L24
> > >
> > > John
> > >
> > >
> > > > *Project 'juneau-server-test' is missing required library:
> > > >
> > > > '/home/james.bognar/.m2/repository/org/apache/juneau/
> > > juneau-client/6.0.0-SNAPSHOT/juneau-client-6.0.0-SNAPSHOT.jar'*
> > > > *Project 'juneau-server-test' is missing required library:
> > > >
> > > > '/home/james.bognar/.m2/repository/org/apache/juneau/
> > > juneau-core/6.0.0-SNAPSHOT/juneau-core-6.0.0-SNAPSHOT.jar'*
> > > > *Project 'juneau-server-test' is missing required library:
> > > >
> > > > '/home/james.bognar/.m2/repository/org/apache/juneau/
> > > juneau-microservice/6.0.0-SNAPSHOT/juneau-microservice-
> > > 6.0.0-SNAPSHOT.jar'*
> > > > *Project 'juneau-server-test' is missing required library:
> > > >
> > > > '/home/james.bognar/.m2/repository/org/apache/juneau/
> > > juneau-samples/6.0.0-SNAPSHOT/juneau-samples-6.0.0-SNAPSHOT.jar'*
> > > > *Project 'juneau-server-test' is missing required library:
> > > >
> > > > '/home/james.bognar/.m2/repository/org/apache/juneau/
> > > juneau-server/6.0.0-SNAPSHOT/juneau-server-6.0.0-SNAPSHOT.jar'*
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > On Tue, Aug 9, 2016 at 10:11 AM, John D. Ament <
> johndament@apache.org>
> > > > wrote:
> > > >
> > > > > How are you opening it? I'm not working on that right now.  All of
> > the
> > > > > files were touched by mvn eclipse:eclipse so they should be valid
> (i
> > > > didn't
> > > > > get this error FWIW)
> > > > >
> > > > > John
> > > > >
> > > > > On Tue, Aug 9, 2016 at 10:08 AM James Bognar <
> > > > james.bognar@salesforce.com>
> > > > > wrote:
> > > > >
> > > > > > Hi John,
> > > > > >
> > > > > > I'm getting some workspace errors from your latest changes.
 For
> > > > example,
> > > > > > some of the .classpath files has an invalid source entry....
> > > > > >   <classpathentry kind="src" path="target/maven-shared-
> > > > > archive-resources"
> > > > > > excluding="**/*.java"/>
> > > > > >
> > > > > > Let me know when you're done editing these projects and I'll
> clean
> > > > these
> > > > > > up.
> > > > > >
> > > > > >
> > > > > > --
> > > > > > James Bognar
> > > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > James Bognar
> > > >
> > >
> >
> >
> >
> > --
> > James Bognar
> >
>



-- 
James Bognar

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message